summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-02-10 11:09:16 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-02-10 11:09:16 +0000
commit72c1caed1be69b3a2e209a75935c555072b4f29b (patch)
tree232f0cea218d658210ceeef572c27ecfb00d3c93 /app-editors/joe
parentsed fixes and other misc (diff)
downloadhistorical-72c1caed1be69b3a2e209a75935c555072b4f29b.tar.gz
historical-72c1caed1be69b3a2e209a75935c555072b4f29b.tar.bz2
historical-72c1caed1be69b3a2e209a75935c555072b4f29b.zip
sed fixes and other misc.
Diffstat (limited to 'app-editors/joe')
-rw-r--r--app-editors/joe/ChangeLog7
-rw-r--r--app-editors/joe/joe-2.9.5.ebuild37
-rw-r--r--app-editors/joe/joe-2.9.8_pre1.ebuild12
3 files changed, 26 insertions, 30 deletions
diff --git a/app-editors/joe/ChangeLog b/app-editors/joe/ChangeLog
index 8e04539e53d0..251520c31f97 100644
--- a/app-editors/joe/ChangeLog
+++ b/app-editors/joe/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for app-editors/joe
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.7 2003/01/06 10:41:54 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/ChangeLog,v 1.8 2003/02/10 11:09:16 seemant Exp $
*joe-2.9.8_pre1 (18 Oct 2002)
@@ -18,6 +18,11 @@
*joe-2.9.5 (1 Feb 2002)
+ 10 Feb 2003; Seemant Kulleen <seemant@gentoo.org> joe-2.9.5.ebuild :
+
+ Changed sed expression delimiters to : from /, closing bug #15006 by Blu3
+ <david+gentoo.org@blue-labs.org>
+
18 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> joe-2.9.5.ebuild :
Updated to mirror://sourceforge in SRC_URI.
diff --git a/app-editors/joe/joe-2.9.5.ebuild b/app-editors/joe/joe-2.9.5.ebuild
index ea91bda847e7..ef746fd1db05 100644
--- a/app-editors/joe/joe-2.9.5.ebuild
+++ b/app-editors/joe/joe-2.9.5.ebuild
@@ -1,50 +1,39 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.5.ebuild,v 1.10 2003/01/06 10:41:54 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.5.ebuild,v 1.11 2003/02/10 11:09:16 seemant Exp $
+
+IUSE=""
S=${WORKDIR}/${P}
DESCRIPTION="A free ASCII-Text Screen Editor for UNIX"
SRC_URI="mirror://sourceforge/joe-editor/${P}.tgz"
HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-PROVIDE="virtual/editor"
-
SLOT="0"
KEYWORDS="x86 ppc sparc "
LICENSE="GPL-1"
-src_unpack() {
-
- unpack ${A}
- cd ${S}
- cp Makefile Makefile.orig
- sed -e "s/-O2/${CFLAGS}/" Makefile.orig > Makefile
-
-}
+DEPEND=">=sys-libs/ncurses-5.2-r2"
-src_compile() {
+PROVIDE="virtual/editor"
+src_compile() {
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
make joe termidx || die
}
-src_install() {
+src_install() {
into /usr
dobin joe
doman joe.1
dolib joerc
for i in jmacs jstar jpico rjoe
do
- dosym joe /usr/bin/$i
- dosym joe.1.gz /usr/share/man/man1/$i.1.gz
- dolib ${i}rc
+ dosym joe /usr/bin/$i
+ dosym joe.1.gz /usr/share/man/man1/$i.1.gz
+ dolib ${i}rc
done
dodoc copying INFO LIST README TODO VERSION
}
-
-
-
-
-
diff --git a/app-editors/joe/joe-2.9.8_pre1.ebuild b/app-editors/joe/joe-2.9.8_pre1.ebuild
index c4d5b988c7ac..323190c4428a 100644
--- a/app-editors/joe/joe-2.9.8_pre1.ebuild
+++ b/app-editors/joe/joe-2.9.8_pre1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.8_pre1.ebuild,v 1.5 2003/01/06 10:41:54 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/joe/joe-2.9.8_pre1.ebuild,v 1.6 2003/02/10 11:09:16 seemant Exp $
+
+IUSE=""
MY_P=${P/_/-}
S=${WORKDIR}/${MY_P}
@@ -9,7 +11,7 @@ SRC_URI="mirror://sourceforge/joe-editor/${MY_P}.tgz"
HOMEPAGE="http://sourceforge.net/projects/joe-editor/"
SLOT="0"
-KEYWORDS="~x86 ppc ~sparc "
+KEYWORDS="~x86 ppc ~sparc"
LICENSE="GPL-1"
DEPEND=">=sys-libs/ncurses-5.2-r2"
@@ -17,11 +19,11 @@ DEPEND=">=sys-libs/ncurses-5.2-r2"
PROVIDE="virtual/editor"
src_compile() {
- econf
+ econf || die
make || die
}
src_install() {
- einstall
+ einstall || die
dodoc COPYING INFO LIST README TODO VERSION
}