summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2001-07-03 14:41:37 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2001-07-03 14:41:37 +0000
commitb7cf0b9330283a4247998682df02559b01d18d06 (patch)
tree4151822340e1af26fa2b4d9bfb3c298bd107319e /app-editors/jed
parentNewer Release of Zsh. (diff)
downloadhistorical-b7cf0b9330283a4247998682df02559b01d18d06.tar.gz
historical-b7cf0b9330283a4247998682df02559b01d18d06.tar.bz2
historical-b7cf0b9330283a4247998682df02559b01d18d06.zip
New ebuild; jed editor.
Diffstat (limited to 'app-editors/jed')
-rw-r--r--app-editors/jed/files/digest-jed-0.99.141
-rw-r--r--app-editors/jed/jed-0.99.14.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-editors/jed/files/digest-jed-0.99.14 b/app-editors/jed/files/digest-jed-0.99.14
new file mode 100644
index 000000000000..6406e9951c48
--- /dev/null
+++ b/app-editors/jed/files/digest-jed-0.99.14
@@ -0,0 +1 @@
+MD5 3023e134d85f72e54f0f9d1c84e5b4e4 jed-B0.99-14.tar.bz2
diff --git a/app-editors/jed/jed-0.99.14.ebuild b/app-editors/jed/jed-0.99.14.ebuild
new file mode 100644
index 000000000000..5d4cb03d4384
--- /dev/null
+++ b/app-editors/jed/jed-0.99.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/jed/jed-0.99.14.ebuild,v 1.1 2001/07/03 14:41:37 g2boojum Exp $
+
+#P=
+P0=${PN}-B0.99-14
+A=${P0}.tar.bz2
+S=${WORKDIR}/${P0}
+DESCRIPTION="Console S-Lang-based editor"
+SRC_URI="ftp://space.mit.edu/pub/davis/jed/v0.99/${A}"
+HOMEPAGE="http://space.mit.edu/~davis/jed/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/slang-1.3.11
+ X? ( virtual/x11 )
+ gpm? ( sys-libs/gpm )"
+
+src_compile() {
+
+ export JED_ROOT=/usr/share/jed
+ try ./configure --prefix=$JED_ROOT --host=${CHOST} --bindir=/usr/bin --mandir=/usr/share/man
+ if [ -n "`use gpm`" ] ; then
+ cd src
+ mv Makefile Makefile.orig
+ sed -e 's/#MOUSEFLAGS/MOUSEFLAGS/' -e 's/#MOUSELIB/MOUSELIB/' -e 's/#GPMMOUSEO/GPMMOUSEO/' -e 's/#OBJGPMMOUSEO/OBJGPMMOUSEO/' Makefile.orig > Makefile
+ cd ..
+ fi
+ try make clean
+ try make
+ if [ -n "`use X`" ] ; then
+ try make xjed
+ fi
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+ cd doc
+ cp README AUTHORS
+ cd ..
+ dodoc COPYING COPYRIGHT INSTALL INSTALL.unx README doc/AUTHORS doc/manual/jed.tex
+ insinto /usr/share/info
+ doins info/*
+ insinto /etc
+ doins lib/jed.conf
+ cd ${D}
+ rm -rf usr/share/jed/info
+ # can't rm usr/share/jed/doc -- used internally by jed/xjed
+
+}
+