summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2002-07-25 19:09:03 +0000
committerDamon Conway <kabau@gentoo.org>2002-07-25 19:09:03 +0000
commitcaf1b58f18edcd0f1ff8a3737fafbca3883a2836 (patch)
tree22351c077901501a39912efae5c0ee217f6f99f0 /app-editors/e3
parentrepoman'd (diff)
downloadhistorical-caf1b58f18edcd0f1ff8a3737fafbca3883a2836.tar.gz
historical-caf1b58f18edcd0f1ff8a3737fafbca3883a2836.tar.bz2
historical-caf1b58f18edcd0f1ff8a3737fafbca3883a2836.zip
Added SLOT, KEYWORDS, and LICENSE. Also fixed spacing and depricated try syntax.
Diffstat (limited to 'app-editors/e3')
-rw-r--r--app-editors/e3/e3-1.7-r1.ebuild14
-rw-r--r--app-editors/e3/e3-1.7-r2.ebuild12
-rw-r--r--app-editors/e3/e3-1.7.ebuild16
-rw-r--r--app-editors/e3/e3-2.33.ebuild12
4 files changed, 27 insertions, 27 deletions
diff --git a/app-editors/e3/e3-1.7-r1.ebuild b/app-editors/e3/e3-1.7-r1.ebuild
index 13c72606d005..7b6644eb8e1c 100644
--- a/app-editors/e3/e3-1.7-r1.ebuild
+++ b/app-editors/e3/e3-1.7-r1.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
#
-# NOTE: this is an x86-only ebuild!!!
-#
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r1.ebuild,v 1.4 2002/07/25 03:43:02 kabau Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r1.ebuild,v 1.5 2002/07/25 19:09:03 kabau Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
HOMEPAGE="http://www.sax.de/~adlibit"
-KEYWORDS="x86"
-LICENSE="GPL"
DEPEND="dev-lang/nasm
>=sys-apps/gzip-1.2.4a-r6"
RDEPEND="sys-apps/sed"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
}
src_compile() {
- try emake
+ emake || die
}
src_install () {
diff --git a/app-editors/e3/e3-1.7-r2.ebuild b/app-editors/e3/e3-1.7-r2.ebuild
index 66bf561e39a6..2883ac2a8c45 100644
--- a/app-editors/e3/e3-1.7-r2.ebuild
+++ b/app-editors/e3/e3-1.7-r2.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
#
-# NOTE: this is an x86-only ebuild!!!
-#
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r2.ebuild,v 1.11 2002/07/25 03:43:03 kabau Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7-r2.ebuild,v 1.12 2002/07/25 19:09:03 kabau Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
HOMEPAGE="http://www.sax.de/~adlibit"
-KEYWORDS="x86"
-LICENSE="GPL"
DEPEND="dev-lang/nasm"
RDEPEND="sys-apps/sed"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}
diff --git a/app-editors/e3/e3-1.7.ebuild b/app-editors/e3/e3-1.7.ebuild
index e257c959ac6d..bec84b9d72dc 100644
--- a/app-editors/e3/e3-1.7.ebuild
+++ b/app-editors/e3/e3-1.7.ebuild
@@ -1,18 +1,18 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
#
-# NOTE: this is an x86-only ebuild!!!
-#
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7.ebuild,v 1.5 2002/07/25 03:43:03 kabau Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-1.7.ebuild,v 1.6 2002/07/25 19:09:03 kabau Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
HOMEPAGE="http://www.sax.de/~adlibit"
-KEYWORDS="x86"
-LICENSE="GPL"
DEPEND="dev-lang/nasm"
-#RDEPEND=""
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 -ppc -sparc -sparc64"
src_unpack() {
unpack ${A}
@@ -21,7 +21,7 @@ src_unpack() {
}
src_compile() {
- try emake
+ emake || die
}
src_install () {
diff --git a/app-editors/e3/e3-2.33.ebuild b/app-editors/e3/e3-2.33.ebuild
index 6c65ce8b4362..524fad5075ed 100644
--- a/app-editors/e3/e3-2.33.ebuild
+++ b/app-editors/e3/e3-2.33.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
#
-# NOTE: this is an x86-only ebuild!!!
-#
-# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-2.33.ebuild,v 1.3 2002/07/25 03:43:03 kabau Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/e3/e3-2.33.ebuild,v 1.4 2002/07/25 19:09:03 kabau Exp $
S=${WORKDIR}/${P}
DESCRIPTION="Super Tiny Editor with wordstar, vi, and emacs key bindings"
SRC_URI="http://www.sax.de/~adlibit/${P}.tar.gz"
HOMEPAGE="http://www.sax.de/~adlibit"
-KEYWORDS="x86"
-LICENSE="GPL"
DEPEND="dev-lang/nasm"
RDEPEND="sys-apps/sed"
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
src_unpack() {
unpack ${A}
cd ${WORKDIR}