summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-01-06 12:25:51 +0000
committerFabian Groffen <grobian@gentoo.org>2006-01-06 12:25:51 +0000
commitc584faf4243cb340acdd0cc2766da057ddf97f18 (patch)
tree37b15f130b7344f7081e67c1f6f17bdf8aac5d6b /app-crypt
parentInitial import of ebuild, thanks to Ben De luca <bedel@allmail.net>, Bug #48741 (diff)
downloadhistorical-c584faf4243cb340acdd0cc2766da057ddf97f18.tar.gz
historical-c584faf4243cb340acdd0cc2766da057ddf97f18.tar.bz2
historical-c584faf4243cb340acdd0cc2766da057ddf97f18.zip
Fixed ebuild and marked ~ppc-macos (bug #106606)
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/johntheripper/ChangeLog10
-rw-r--r--app-crypt/johntheripper/Manifest4
-rw-r--r--app-crypt/johntheripper/johntheripper-1.6.38.ebuild14
3 files changed, 17 insertions, 11 deletions
diff --git a/app-crypt/johntheripper/ChangeLog b/app-crypt/johntheripper/ChangeLog
index c40e2e2660c6..bd8941b5cddf 100644
--- a/app-crypt/johntheripper/ChangeLog
+++ b/app-crypt/johntheripper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/johntheripper
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.31 2005/09/20 15:01:21 vanquirius Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/ChangeLog,v 1.32 2006/01/06 12:25:51 grobian Exp $
+
+ 06 Jan 2006; Fabian Groffen <grobian@gentoo.org>
+ johntheripper-1.6.38.ebuild:
+ Allow compilation on ppc-macos again; in elseif statements, have most specific
+ match first. Now the right case is matched, also fix the make target
+ invocation. Marked ~ppc-macos (bug #106606)
20 Sep 2005; Marcelo Goes <vanquirius@gentoo.org>
johntheripper-1.6-r3.ebuild:
diff --git a/app-crypt/johntheripper/Manifest b/app-crypt/johntheripper/Manifest
index 5fec60411023..0d8e51ed510d 100644
--- a/app-crypt/johntheripper/Manifest
+++ b/app-crypt/johntheripper/Manifest
@@ -1,8 +1,8 @@
MD5 0c4cbd4e5b8ebb91bf48eaea23aaa69f johntheripper-1.6-r3.ebuild 2643
-MD5 373b3ff3bae57cff973505b133c2fe0c johntheripper-1.6.38.ebuild 2128
+MD5 627ea8b517a40b86c7ff58c326a15c5c johntheripper-1.6.38.ebuild 2124
MD5 dfb8cfe55b695afa3d3fd24deabc7279 johntheripper-1.6.ebuild 1329
MD5 47f5a4e19f2bcb5e25dda3ced7e7239f johntheripper-1.6.37_p11.ebuild 2412
-MD5 cefb78f7a0337eafc0631f5320d8d67d ChangeLog 5894
+MD5 86aca1949f86362735e5164b32e7e917 ChangeLog 6174
MD5 1da04b916dc5d18f323ec583c17a7208 metadata.xml 259
MD5 b007eb04f5b4d9f7a127277e9736c65d files/digest-johntheripper-1.6.38 63
MD5 c44028343f13bf0e4ff431cca80988d9 files/digest-johntheripper-1.6-r3 126
diff --git a/app-crypt/johntheripper/johntheripper-1.6.38.ebuild b/app-crypt/johntheripper/johntheripper-1.6.38.ebuild
index d51245e49dcf..22d229bf4800 100644
--- a/app-crypt/johntheripper/johntheripper-1.6.38.ebuild
+++ b/app-crypt/johntheripper/johntheripper-1.6.38.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.38.ebuild,v 1.3 2005/08/23 21:37:47 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/johntheripper/johntheripper-1.6.38.ebuild,v 1.4 2006/01/06 12:25:51 grobian Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="http://www.openwall.com/john/c/${MY_PBASE}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~sparc ~ppc ~alpha ~amd64 ~ppc64 ~mips ~hppa"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
IUSE="mmx"
RDEPEND="virtual/libc"
@@ -38,8 +38,6 @@ src_compile() {
emake ${OPTIONS} linux-alpha || die "Make failed"
elif use sparc; then
emake ${OPTIONS} linux-sparc || die "Make failed"
- elif use ppc; then
- emake ${OPTIONS} linux-ppc || die "Make failed"
elif use amd64; then
if use mmx; then
emake ${OPTIONS} linux-x86-64-mmx || die "Make failed"
@@ -47,8 +45,10 @@ src_compile() {
emake ${OPTIONS} linux-x86-64 || die "Make failed"
fi
elif use ppc-macos; then
- emake ${OPTIONS} macosx-ppc-altivec-cc || die "Make failed"
- #emake ${OPTIONS} macosx-ppc-cc || die "Make failed"
+ emake ${OPTIONS} macosx-ppc32-altivec-cc || die "Make failed"
+ # for Tiger this can be macosx-ppc64-cc
+ elif use ppc; then
+ emake ${OPTIONS} linux-ppc || die "Make failed"
else
emake ${OPTIONS} generic || die "Make failed"
fi