summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-05-05 01:05:34 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-05-05 01:05:34 +0000
commit433bb67a8c036f95feed8aaa1c8365de3c0f7c42 (patch)
treefd79a2f80c1a42e9b06e0a0c4b13e9c8021878d1 /app-crypt
parentAdded GDM-gentoo-emergance_2 to close bug 20004 (diff)
downloadhistorical-433bb67a8c036f95feed8aaa1c8365de3c0f7c42.tar.gz
historical-433bb67a8c036f95feed8aaa1c8365de3c0f7c42.tar.bz2
historical-433bb67a8c036f95feed8aaa1c8365de3c0f7c42.zip
Version bump.
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog7
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.21
-rw-r--r--app-crypt/gnupg/gnupg-1.2.2.ebuild55
3 files changed, 62 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 1f2d47aa8c13..52f016214b28 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.19 2003/04/06 19:34:59 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.20 2003/05/05 01:05:34 jrray Exp $
+
+*gnupg-1.2.2 (04 May 2003)
+
+ 04 May 2003; <jrray@gentoo.org> gnupg-1.2.2.ebuild:
+ Simple version bump, new version includes minor security fixes.
26 Dec 2002; Maik Schreiber <blizzy@gentoo.org> gnupg-1.2.1-r1.ebuild:
Changed "~x86" to "x86" in KEYWORDS.
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.2 b/app-crypt/gnupg/files/digest-gnupg-1.2.2
new file mode 100644
index 000000000000..c9f5676d4406
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.2
@@ -0,0 +1 @@
+MD5 4e1b357b22e1d45d14d340ce03d39b63 gnupg-1.2.2.tar.bz2 2225034
diff --git a/app-crypt/gnupg/gnupg-1.2.2.ebuild b/app-crypt/gnupg/gnupg-1.2.2.ebuild
new file mode 100644
index 000000000000..4cfb1997a4ac
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.2.ebuild,v 1.1 2003/05/05 01:05:34 jrray Exp $
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~arm"
+IUSE="X zlib ldap nls"
+
+DEPEND="dev-lang/perl
+ X? ( x11-misc/xloadimage )
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ldap || myconf="${myconf} --disable-ldap"
+ use zlib || myconf="${myconf} --with-included-zlib"
+ use X || myconf="${myconf} --disable-photo-viewers"
+
+ #Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf}
+ make || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog OpenPGP
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}