summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-12-31 00:48:22 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-12-31 00:48:22 +0000
commit0a58ac06547405334edccee1a6cd6d6dfdc561f2 (patch)
tree4fa89407c643557fbceaa463004a527dfe568d14 /app-crypt
parentnew version (diff)
downloadhistorical-0a58ac06547405334edccee1a6cd6d6dfdc561f2.tar.gz
historical-0a58ac06547405334edccee1a6cd6d6dfdc561f2.tar.bz2
historical-0a58ac06547405334edccee1a6cd6d6dfdc561f2.zip
added krb4 and krb5 from KTH
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/heimdal/files/01heimdal5
-rw-r--r--app-crypt/heimdal/files/digest-heimdal-0.4e1
-rw-r--r--app-crypt/heimdal/heimdal-0.4e.ebuild57
-rw-r--r--app-crypt/kth-krb/files/02kth-krb5
-rw-r--r--app-crypt/kth-krb/files/digest-kth-krb-1.11
-rw-r--r--app-crypt/kth-krb/kth-krb-1.1.ebuild41
6 files changed, 110 insertions, 0 deletions
diff --git a/app-crypt/heimdal/files/01heimdal b/app-crypt/heimdal/files/01heimdal
new file mode 100644
index 000000000000..02c62192e227
--- /dev/null
+++ b/app-crypt/heimdal/files/01heimdal
@@ -0,0 +1,5 @@
+PATH=/usr/heimdal/bin
+ROOTPATH=/usr/heimdal/sbin
+LDPATH=/usr/heimdal/lib
+MANPATH=/usr/heimdal/man
+INFOPATH=/usr/heimdal/info
diff --git a/app-crypt/heimdal/files/digest-heimdal-0.4e b/app-crypt/heimdal/files/digest-heimdal-0.4e
new file mode 100644
index 000000000000..b2bfa8751a0e
--- /dev/null
+++ b/app-crypt/heimdal/files/digest-heimdal-0.4e
@@ -0,0 +1 @@
+MD5 239aa6841881f77db64faeaea47d7593 heimdal-0.4e.tar.gz 2895872
diff --git a/app-crypt/heimdal/heimdal-0.4e.ebuild b/app-crypt/heimdal/heimdal-0.4e.ebuild
new file mode 100644
index 000000000000..044b920f7f58
--- /dev/null
+++ b/app-crypt/heimdal/heimdal-0.4e.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/heimdal/heimdal-0.4e.ebuild,v 1.1 2001/12/31 00:48:22 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Kerberos 5 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/${PN}/src/${P}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/heimdal/"
+
+DEPEND="virtual/glibc
+ >=app-crypt/kth-krb-1.1
+ ssl? ( dev-libs/openssl-0.9.6b )
+ ldap? ( net-nds/openldap )
+ berkdb? ( sys-libs/db )"
+
+src_compile() {
+ local myconf
+
+ if [ "`use ssl`" ] ; then
+ myconf="--with-openssl=/usr"
+ fi
+
+ if [ "`use ldap`" ] ; then
+ myconf="${myconf} --with-open-ldap=/usr"
+ fi
+
+ if [ -z "`use ipv6`" ] ; then
+ myconf="${myconf} --without-ipv6"
+ fi
+
+ if [ -z "`use berkdb`" ] ; then
+ myconf="${myconf} --without-berkely-db"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/heimdal \
+ --sysconfdir=/etc \
+ --with-krb4=/usr/athena \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr/heimdal \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/01heimdal ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}
+
+
+
diff --git a/app-crypt/kth-krb/files/02kth-krb b/app-crypt/kth-krb/files/02kth-krb
new file mode 100644
index 000000000000..fd94515ddcbe
--- /dev/null
+++ b/app-crypt/kth-krb/files/02kth-krb
@@ -0,0 +1,5 @@
+PATH=/usr/athena/bin
+ROOTPATH=/usr/athena/sbin
+LDPATH=/usr/athena/lib
+MANDIR=/usr/athena/man
+INFODIR=/usr/athena/info
diff --git a/app-crypt/kth-krb/files/digest-kth-krb-1.1 b/app-crypt/kth-krb/files/digest-kth-krb-1.1
new file mode 100644
index 000000000000..4060d9eb5681
--- /dev/null
+++ b/app-crypt/kth-krb/files/digest-kth-krb-1.1
@@ -0,0 +1 @@
+MD5 fc7a9f7a0d1c81e93a31a9409ee7ea00 krb4-1.1.tar.gz 1814528
diff --git a/app-crypt/kth-krb/kth-krb-1.1.ebuild b/app-crypt/kth-krb/kth-krb-1.1.ebuild
new file mode 100644
index 000000000000..1b3222b7379d
--- /dev/null
+++ b/app-crypt/kth-krb/kth-krb-1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kth-krb/kth-krb-1.1.ebuild,v 1.1 2001/12/31 00:48:22 hallski Exp $
+
+S=${WORKDIR}/krb4-${PV}
+DESCRIPTION="Kerberos 4 implementation from KTH"
+SRC_URI="ftp://ftp.pdc.kth.se/pub/krb/src/krb4-${PV}.tar.gz"
+HOMEPAGE="http://www.pdc.kth.se/kth-krb/"
+
+DEPEND="virtual/glibc
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_compile() {
+ local myconf
+
+ if [ "`use ssl`" ] ; then
+ myconf="--with-openssl=/usr"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr/athena \
+ --sysconfdir=/etc \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr/athena \
+ sysconfdir=${D}/etc \
+ install || die
+
+ dodir /etc/env.d
+ cp ${FILESDIR}/02kth-krb ${D}/etc/env.d
+
+ dodoc COPYRIGHT ChangeLog README NEWS PROBLEMS TODO
+}
+
+
+