summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJ Robert Ray <jrray@gentoo.org>2003-02-07 14:57:12 +0000
committerJ Robert Ray <jrray@gentoo.org>2003-02-07 14:57:12 +0000
commit0a2ab5b41a28832506a80804d858b1c340897159 (patch)
tree674f5494abbae99fbaa50a95291465686d1c760e /app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild
parentadd ~alpha (diff)
downloadhistorical-0a2ab5b41a28832506a80804d858b1c340897159.tar.gz
historical-0a2ab5b41a28832506a80804d858b1c340897159.tar.bz2
historical-0a2ab5b41a28832506a80804d858b1c340897159.zip
New ebuild
Diffstat (limited to 'app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild')
-rw-r--r--app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild b/app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild
new file mode 100644
index 000000000000..ef08e0158e8f
--- /dev/null
+++ b/app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/quintuple-agent/quintuple-agent-1.0.3.ebuild,v 1.1 2003/02/07 14:57:12 jrray Exp $
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Quintuple Agent stores your (GnuPG) secrets in a secure manner."
+HOMEPAGE="http://www.vibe.at/tools/secret-agent/"
+SRC_URI="http://www.vibe.at/tools/secret-agent/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/glib-1.2.0
+ >=x11-libs/gtk+-1.2.0
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls)
+ emake
+}
+
+src_install () {
+ einstall
+ chmod +s "${D}/usr/bin/q-agent"
+
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS README THANKS TODO
+ docinto doc
+ dodoc doc/*.sgml
+}
+
+pkg_postinst() {
+ einfo "q-agent is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}