summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 20:39:29 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 20:39:29 +0000
commit1cb73ae8cd01b90097c00edde8374e16497110bd (patch)
treebfe2ee8aea814d1794bccb1c58104b06b70fd462 /app-crypt/krb5
parentChanged econf||die to econf (diff)
downloadhistorical-1cb73ae8cd01b90097c00edde8374e16497110bd.tar.gz
historical-1cb73ae8cd01b90097c00edde8374e16497110bd.tar.bz2
historical-1cb73ae8cd01b90097c00edde8374e16497110bd.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-crypt/krb5')
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r1.ebuild18
-rw-r--r--app-crypt/krb5/krb5-1.2.5-r2.ebuild16
-rw-r--r--app-crypt/krb5/krb5-1.2.6.ebuild9
3 files changed, 23 insertions, 20 deletions
diff --git a/app-crypt/krb5/krb5-1.2.5-r1.ebuild b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
index 16a0c20e2bab..91a549b510f7 100644
--- a/app-crypt/krb5/krb5-1.2.5-r1.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r1.ebuild
@@ -1,35 +1,37 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.5 2002/10/04 03:57:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r1.ebuild,v 1.6 2002/11/30 20:33:36 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
-HOMEPAGE="http://crypto-publish.org"
+HOMEPAGE="http://crypto-publish.org/"
SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}
diff --git a/app-crypt/krb5/krb5-1.2.5-r2.ebuild b/app-crypt/krb5/krb5-1.2.5-r2.ebuild
index 7f02d223731e..b329c65932a0 100644
--- a/app-crypt/krb5/krb5-1.2.5-r2.ebuild
+++ b/app-crypt/krb5/krb5-1.2.5-r2.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r2.ebuild,v 1.3 2002/08/16 02:36:53 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.5-r2.ebuild,v 1.4 2002/11/30 20:34:23 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
HOMEPAGE="http://web.mit.edu/kerberos/www/"
@@ -11,10 +10,9 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_compile() {
-
patch -p0 < ${FILESDIR}/${PN}-1.2.2-gentoo.diff || die
cd ${S}/lib/rpc
@@ -24,16 +22,20 @@ src_compile() {
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
+
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README
- echo 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
+}
+
+pkg_postinst() {
+ ewarn 'NOTE: ftp, telnet, r* apps not installed. Install pam-krb5!'
}
diff --git a/app-crypt/krb5/krb5-1.2.6.ebuild b/app-crypt/krb5/krb5-1.2.6.ebuild
index 45e35ed3c3d2..6bca36a7783c 100644
--- a/app-crypt/krb5/krb5-1.2.6.ebuild
+++ b/app-crypt/krb5/krb5-1.2.6.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.6.ebuild,v 1.1 2002/10/28 14:01:18 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/krb5/krb5-1.2.6.ebuild,v 1.2 2002/11/30 20:35:04 vapier Exp $
-S=${WORKDIR}/${P}/src
SRC_URI="http://www.crypto-publish.org/dist/mit-kerberos5/${P}.tar.gz"
DESCRIPTION="MIT Kerberos V (set up for pam)"
HOMEPAGE="http://web.mit.edu/kerberos/www/"
@@ -12,7 +11,7 @@ SLOT="0"
LICENSE="as-is"
KEYWORDS="x86 sparc sparc64"
-DEPEND="virtual/glibc"
+S=${WORKDIR}/${P}/src
src_unpack() {
unpack ${A}
@@ -28,14 +27,14 @@ src_compile() {
econf \
--with-krb4 \
--enable-shared \
- --enable-dns || die
+ --enable-dns
mv Makefile Makefile.orig
#Don't install the ftp, telnet, r* apps; use pam instead
sed -e 's/ appl / /' Makefile.orig > Makefile
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
cd ..
dodoc README