summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-31 20:52:38 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-31 20:52:38 +0000
commit9494645b8a9e9ad6dffdfb844b97152d203d28de (patch)
tree18a6ebc858da112241bf3e8934cf4ae218748da5 /app-crypt/gnupg
parentlicq Qt themes (diff)
downloadhistorical-9494645b8a9e9ad6dffdfb844b97152d203d28de.tar.gz
historical-9494645b8a9e9ad6dffdfb844b97152d203d28de.tar.bz2
historical-9494645b8a9e9ad6dffdfb844b97152d203d28de.zip
Version bump
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/ChangeLog7
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.2.11
-rw-r--r--app-crypt/gnupg/gnupg-1.2.1.ebuild55
3 files changed, 62 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 34d1c884ec26..5797a5750e48 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.8 2002/10/21 06:34:54 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.9 2002/10/31 20:52:38 rphillips Exp $
+
+*gnupg-1.2.1 (31 Oct 2002)
+
+ 31 Oct 2002; Ryan Phillips <rphillips@gentoo.org> gnupg-1.2.1.ebuild :
+ Version bump
*gnupg-1.2.0 (18 Oct 2002)
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.2.1 b/app-crypt/gnupg/files/digest-gnupg-1.2.1
new file mode 100644
index 000000000000..f2c49a1b4492
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.2.1
@@ -0,0 +1 @@
+MD5 e63add33e010b4224ba0841b21fe0bfe gnupg-1.2.1.tar.bz2 1889079
diff --git a/app-crypt/gnupg/gnupg-1.2.1.ebuild b/app-crypt/gnupg/gnupg-1.2.1.ebuild
new file mode 100644
index 000000000000..4d7c3e94b712
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.2.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.2.1.ebuild,v 1.1 2002/10/31 20:52:38 rphillips Exp $
+
+IUSE="zlib ldap nls"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/gnupg/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="sys-devel/perl
+ zlib? ( sys-libs/zlib )
+ ldap? ( net-nds/openldap )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+ use nls || myconf="${myconf} --disable-nls"
+ use ldap || myconf="${myconf} --disable-ldap"
+ use zlib || myconf="${myconf} --with-included-zlib"
+
+ #Still needed?
+ # Bug #6387, --enable-m-guard causes bus error on sparcs
+ if [ "${ARCH}" != "sparc" -a "${ARCH}" != "sparc64" ]; then
+ myconf="${myconf} --enable-m-guard"
+ fi
+
+ econf ${myconf} || die
+ emake || make || die
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS README THANKS TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog OpenPGP
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s "${D}/usr/bin/gpg"
+}
+
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
+}