summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-06-03 16:54:36 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-06-03 16:54:36 +0000
commit2b121148aec75e8cb99383d2aad36cff9715cc19 (patch)
treef691a08c1d5fec26e460b63266e47e4ad7844ef7 /app-crypt/gnupg
parent*** empty log message *** (diff)
downloadhistorical-2b121148aec75e8cb99383d2aad36cff9715cc19.tar.gz
historical-2b121148aec75e8cb99383d2aad36cff9715cc19.tar.bz2
historical-2b121148aec75e8cb99383d2aad36cff9715cc19.zip
Somehow this didn't get committed...
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.0.61
-rw-r--r--app-crypt/gnupg/gnupg-1.0.6.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.0.6 b/app-crypt/gnupg/files/digest-gnupg-1.0.6
new file mode 100644
index 000000000000..6c92e924e2f2
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.0.6
@@ -0,0 +1 @@
+MD5 7c319a9e5e70ad9bc3bf0d7b5008a508 gnupg-1.0.6.tar.gz
diff --git a/app-crypt/gnupg/gnupg-1.0.6.ebuild b/app-crypt/gnupg/gnupg-1.0.6.ebuild
new file mode 100644
index 000000000000..1808890b1c12
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens
+# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
+# 2001/04/21 12:45 CST blutgens Exp $
+
+#P=
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${A}"
+HOMEPAGE="http://www.gnupg.org/"
+
+DEPEND="virtual/glibc
+ nls? ( >=sys-devel/gettext-0.10.35 )
+ >=sys-libs/zlib-1.1.3"
+
+src_compile() {
+
+# Check to see if we're using nls
+ local myconf
+ if [ -z "`use nls`" ]; then
+ myconf="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share --infodir=/usr/share/info \
+ --enable-static-rnd=linux --enable-m-guard --host=${CHOST}\
+ ${myconf}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog
+ docint sgml
+ dodoc gpg.sgml gpgv.sgml
+ docinto html
+ dodoc faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s ${D}/usr/bin/gpg
+}
+