summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-08-16 05:58:03 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-08-16 05:58:03 +0000
commit26a2cbd52839ea3485384cc86e08c80b8a7d21c7 (patch)
tree7a44c051aec5d56e0d0877d5e21d9bde4628df58 /app-crypt/gnupg
parentI thought I already committed this? This is the ebuild for pam with (diff)
downloadhistorical-26a2cbd52839ea3485384cc86e08c80b8a7d21c7.tar.gz
historical-26a2cbd52839ea3485384cc86e08c80b8a7d21c7.tar.bz2
historical-26a2cbd52839ea3485384cc86e08c80b8a7d21c7.zip
added some patches for screen and and gnupg that fixes the info problems.
removed some old digests and upgraded screen. I was pretty sure I committed the screen ebuild a while back.... apparently not.
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.0.51
-rw-r--r--app-crypt/gnupg/files/gnupg-1.0.6.diff34
-rw-r--r--app-crypt/gnupg/gnupg-1.0.6.ebuild21
3 files changed, 51 insertions, 5 deletions
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.0.5 b/app-crypt/gnupg/files/digest-gnupg-1.0.5
deleted file mode 100644
index bb871cdbf691..000000000000
--- a/app-crypt/gnupg/files/digest-gnupg-1.0.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 44c71c3f5a9edbf5738cafc37e8359e6 gnupg-1.0.5.tar.gz
diff --git a/app-crypt/gnupg/files/gnupg-1.0.6.diff b/app-crypt/gnupg/files/gnupg-1.0.6.diff
new file mode 100644
index 000000000000..0a0a9904cc78
--- /dev/null
+++ b/app-crypt/gnupg/files/gnupg-1.0.6.diff
@@ -0,0 +1,34 @@
+diff -rNu gnupg-1.0.6.clean/doc/gpg.texi gnupg-1.0.6/doc/gpg.texi
+--- gnupg-1.0.6.clean/doc/gpg.texi Sat Apr 28 13:43:43 2001
++++ gnupg-1.0.6/doc/gpg.texi Thu Aug 16 00:10:11 2001
+@@ -7,7 +7,12 @@
+ @c patches, etc. to Steve Cheng <steve@ggi-project.org>.
+
+ @setfilename gpg.info
+-
++@format
++INFO-DIR-SECTION Utilities
++START-INFO-DIR-ENTRY
++* Encryption and Signing tools: (gpg). Sign and encrypt files
++END-INFO-DIR-ENTRY
++@end format
+ @node top
+ @top gpg
+ @menu
+diff -rNu gnupg-1.0.6.clean/doc/gpgv.texi gnupg-1.0.6/doc/gpgv.texi
+--- gnupg-1.0.6.clean/doc/gpgv.texi Sat Apr 28 13:40:40 2001
++++ gnupg-1.0.6/doc/gpgv.texi Thu Aug 16 00:10:38 2001
+@@ -7,7 +7,12 @@
+ @c patches, etc. to Steve Cheng <steve@ggi-project.org>.
+
+ @setfilename gpgv.info
+-
++@format
++INFO-DIR-SECTION Utilities
++START-INFO-DIR-ENTRY
++* signature verification: (gpgv). signature verification tool
++END-INFO-DIR-ENTRY
++@end format
+ @node top
+ @top gpgv
+ @menu
diff --git a/app-crypt/gnupg/gnupg-1.0.6.ebuild b/app-crypt/gnupg/gnupg-1.0.6.ebuild
index 2b4637b8519a..54cc8189ed02 100644
--- a/app-crypt/gnupg/gnupg-1.0.6.ebuild
+++ b/app-crypt/gnupg/gnupg-1.0.6.ebuild
@@ -15,6 +15,12 @@ DEPEND="virtual/glibc
nls? ( >=sys-devel/gettext-0.10.35 )
>=sys-libs/zlib-1.1.3"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+# Fix those $&*%^$%%$ info files
+ patch -p1 < ${FILESDIR}/gnupg-1.0.6.diff
+}
src_compile() {
# Check to see if we're using nls
@@ -23,8 +29,9 @@ src_compile() {
myconf="--disable-nls"
fi
- try ./configure --prefix=/usr --mandir=/usr/share --infodir=/usr/share/info \
- --enable-static-rnd=linux --enable-m-guard --host=${CHOST}\
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --infodir=/usr/share/info --enable-static-rnd=linux \
+ --enable-m-guard --host=${CHOST}\
${myconf}
try pmake
@@ -32,13 +39,13 @@ src_compile() {
src_install () {
- try make prefix=${D}/usr mandir=${D}/usr/share/man infodir=${D}/usr/share/info install
+ try make DESTDIR=${D} install
dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
dodoc README TODO VERSION
docinto doc
cd doc
dodoc FAQ HACKING DETAILS ChangeLog
- docint sgml
+ docinto sgml
dodoc gpg.sgml gpgv.sgml
docinto html
dodoc faq.html
@@ -47,3 +54,9 @@ src_install () {
chmod +s ${D}/usr/bin/gpg
}
+pkg_postinst() {
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place"
+ einfo " to store yourpassphrases etc during runtime"
+ einfo "but may make some sysadmins nervous"
+}