summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-07-25 15:31:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-07-25 15:31:25 +0000
commit018b264c0ea7d19d6d660aaff533f3a152671f07 (patch)
treed6a953656c068726f0f720c97f20429a5cf37a68 /app-crypt/gnupg
parentzoo unmasked, license resolved (diff)
downloadhistorical-018b264c0ea7d19d6d660aaff533f3a152671f07.tar.gz
historical-018b264c0ea7d19d6d660aaff533f3a152671f07.tar.bz2
historical-018b264c0ea7d19d6d660aaff533f3a152671f07.zip
repoman'd
Diffstat (limited to 'app-crypt/gnupg')
-rw-r--r--app-crypt/gnupg/gnupg-1.0.7.ebuild81
1 files changed, 40 insertions, 41 deletions
diff --git a/app-crypt/gnupg/gnupg-1.0.7.ebuild b/app-crypt/gnupg/gnupg-1.0.7.ebuild
index 2c563e626b63..f5d1c65968e9 100644
--- a/app-crypt/gnupg/gnupg-1.0.7.ebuild
+++ b/app-crypt/gnupg/gnupg-1.0.7.ebuild
@@ -1,63 +1,62 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# $Header: /home/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.0.4.ebuild,v 1.0
# 2001/04/21 12:45 CST blutgens Exp $
+S="${WORKDIR}/${P}"
DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
HOMEPAGE="http://www.gnupg.org/"
SRC_URI="ftp://ftp.gnupg.org/pub/gcrypt/gnupg/${P}.tar.gz"
-S="${WORKDIR}/${P}"
-DEPEND="virtual/glibc
- nls? ( >=sys-devel/gettext-0.10.35 )
- >=sys-libs/zlib-1.1.3"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=sys-libs/zlib-1.1.3"
+RDEPEND="nls? ( sys-devel/gettext )"
+
src_unpack() {
- unpack "${A}"
- cd "${S}"
- # Fix those $&*%^$%%$ info files
- patch -p1 < "${FILESDIR}/gnupg-1.0.6.diff"
+ unpack "${A}"
+ cd "${S}"
+ # Fix those $&*%^$%%$ info files
+ patch -p1 < "${FILESDIR}/gnupg-1.0.6.diff"
}
src_compile() {
- # Check to see if we're using nls
- local myconf
- if [ -z "`use nls`" ]; then
- myconf="--disable-nls"
- fi
-
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --enable-static-rnd=linux \
- --enable-m-guard --host="${CHOST}" \
- ${myconf} || die
- emake || die
+ local myconf
+ use nls || myconf="--disable-nls"
+
+ econf \
+ --enable-static-rnd=linux \
+ --enable-m-guard --host="${CHOST}" \
+ ${myconf} || die
+
+ emake || die
}
src_install () {
- make DESTDIR="${D}" install || die
- dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
- dodoc README TODO VERSION
- docinto doc
- cd doc
- dodoc FAQ HACKING DETAILS ChangeLog
- docinto sgml
- dodoc gpg.sgml gpgv.sgml
- dohtml faq.html
- docinto txt
- dodoc faq.raw
- chmod +s "${D}/usr/bin/gpg"
+ make DESTDIR="${D}" install || die
+ dodoc ABOUT-NLS AUTHORS BUGS COPYING ChangeLog INSTALL NEWS PROJECTS
+ dodoc README TODO VERSION
+ docinto doc
+ cd doc
+ dodoc FAQ HACKING DETAILS ChangeLog
+ docinto sgml
+ dodoc gpg.sgml gpgv.sgml
+ dohtml faq.html
+ docinto txt
+ dodoc faq.raw
+ chmod +s "${D}/usr/bin/gpg"
}
pkg_postinst() {
- einfo "gpg is installed SUID root to make use of protected memory space"
- einfo "This is needed in order to have a secure place to store your passphrases,"
- einfo "etc. at runtime but may make some sysadmins nervous"
+ einfo "gpg is installed SUID root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your passphrases,"
+ einfo "etc. at runtime but may make some sysadmins nervous"
echo " "
einfo "Note: this version is not backwards compatible with gnupg-1.0.6."
- einfo " To update your keyrings run: gpg --rebuild-keydb-caches"
- einfo " To backup your keyrings run: gpg --export-ownertrust"
- einfo " and copy the keyrings out of your ~/.gnupg directory."
+ einfo " To update your keyrings run: gpg --rebuild-keydb-caches"
+ einfo " To backup your keyrings run: gpg --export-ownertrust"
+ einfo " and copy the keyrings out of your ~/.gnupg directory."
}