summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTravis Tilley <lv@gentoo.org>2004-05-05 03:56:27 +0000
committerTravis Tilley <lv@gentoo.org>2004-05-05 03:56:27 +0000
commitc0d2a6abe605604741fef669be6d40261d5fc6cb (patch)
tree215bf2942abec6bb4c9e569fc990df131eac680e /app-crypt/cryptplug
parentadded patch for gcc 3.4 from Andrew Sayman via bug #49470 (diff)
downloadhistorical-c0d2a6abe605604741fef669be6d40261d5fc6cb.tar.gz
historical-c0d2a6abe605604741fef669be6d40261d5fc6cb.tar.bz2
historical-c0d2a6abe605604741fef669be6d40261d5fc6cb.zip
version bump with general 64bit fixes. i"m marking this stable on amd64 from the get-go
Diffstat (limited to 'app-crypt/cryptplug')
-rw-r--r--app-crypt/cryptplug/ChangeLog10
-rw-r--r--app-crypt/cryptplug/Manifest6
-rw-r--r--app-crypt/cryptplug/cryptplug-0.3.16.ebuild24
-rw-r--r--app-crypt/cryptplug/files/cryptplug-0.3.16-64bit.dif20
-rw-r--r--app-crypt/cryptplug/files/cryptplug-0.3.16-initialize-fix.diff10
-rw-r--r--app-crypt/cryptplug/files/digest-cryptplug-0.3.161
6 files changed, 69 insertions, 2 deletions
diff --git a/app-crypt/cryptplug/ChangeLog b/app-crypt/cryptplug/ChangeLog
index 8abee09fa978..4a1c3019bd70 100644
--- a/app-crypt/cryptplug/ChangeLog
+++ b/app-crypt/cryptplug/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-crypt/cryptplug
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/ChangeLog,v 1.9 2004/02/25 14:55:05 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/ChangeLog,v 1.10 2004/05/05 03:56:27 lv Exp $
+
+*cryptplug-0.3.16 (04 May 2004)
+
+ 04 May 2004; Travis Tilley <lv@gentoo.org>
+ +files/cryptplug-0.3.16-64bit.dif,
+ +files/cryptplug-0.3.16-initialize-fix.diff, +cryptplug-0.3.16.ebuild:
+ version bump with general 64bit fixes. i'm marking this stable on amd64 from
+ the get-go.
25 Feb 2004; Guy Martin <gmsoft@gentoo.org> cryptplug-0.3.15.ebuild:
Marked stable on hppa.
diff --git a/app-crypt/cryptplug/Manifest b/app-crypt/cryptplug/Manifest
index 81b75d2eeb6d..86d2f64df456 100644
--- a/app-crypt/cryptplug/Manifest
+++ b/app-crypt/cryptplug/Manifest
@@ -1,3 +1,7 @@
-MD5 1dd1b57c7d9b90dca16150032ec533a3 ChangeLog 1091
+MD5 23ded399c734dbecc2a9ff7ceba0f9cd cryptplug-0.3.16.ebuild 709
MD5 38fe55575b14c3c294e425a9d1b7f50c cryptplug-0.3.15.ebuild 566
+MD5 df9d27f0b38f315bae6525b1325eff93 ChangeLog 1370
MD5 6881ee9859f4eed2fd6de2fa539260f1 files/digest-cryptplug-0.3.15 68
+MD5 fcd6801f3b4a1d686f007e21116d0068 files/digest-cryptplug-0.3.16 68
+MD5 cdccd69cf2aa5ae99581ec0f966ba4ed files/cryptplug-0.3.16-64bit.dif 452
+MD5 6768ce3b7b579632728e609be93e902c files/cryptplug-0.3.16-initialize-fix.diff 365
diff --git a/app-crypt/cryptplug/cryptplug-0.3.16.ebuild b/app-crypt/cryptplug/cryptplug-0.3.16.ebuild
new file mode 100644
index 000000000000..96464fe872ee
--- /dev/null
+++ b/app-crypt/cryptplug/cryptplug-0.3.16.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/cryptplug/cryptplug-0.3.16.ebuild,v 1.1 2004/05/05 03:56:27 lv Exp $
+
+DESCRIPTION="GPG and S/MIME encryption plugins. Use by KMail v1.5 (KDE 3.1) and Mutt"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="ftp://ftp.gnupg.org/gcrypt/alpha/cryptplug/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~hppa amd64 ~alpha ~ia64"
+
+DEPEND="=app-crypt/gpgme-0.3.14"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/cryptplug-0.3.16-64bit.dif
+ epatch ${FILESDIR}/cryptplug-0.3.16-initialize-fix.diff
+}
+
+src_install() {
+ einstall || die
+}
diff --git a/app-crypt/cryptplug/files/cryptplug-0.3.16-64bit.dif b/app-crypt/cryptplug/files/cryptplug-0.3.16-64bit.dif
new file mode 100644
index 000000000000..74142babbc3e
--- /dev/null
+++ b/app-crypt/cryptplug/files/cryptplug-0.3.16-64bit.dif
@@ -0,0 +1,20 @@
+--- gpgme/gpgmeplug.c
++++ gpgme/gpgmeplug.c 2003/02/21 15:56:32
+@@ -1776,7 +1776,7 @@
+ GpgmeError err;
+ GpgmeCtx ctx;
+ GpgmeData pub;
+- int len;
++ size_t len;
+
+ err = gpgme_data_new (&pub);
+ fprintf( stderr, "1: gpgme returned %d\n", err );
+@@ -1803,7 +1803,7 @@
+
+ gpgme_release (ctx);
+ *generatedKey = gpgme_data_release_and_get_mem (pub, &len);
+- *length = len;
++ *length = (int)len;
+
+ return true;
+ }
diff --git a/app-crypt/cryptplug/files/cryptplug-0.3.16-initialize-fix.diff b/app-crypt/cryptplug/files/cryptplug-0.3.16-initialize-fix.diff
new file mode 100644
index 000000000000..fa9ee4c51342
--- /dev/null
+++ b/app-crypt/cryptplug/files/cryptplug-0.3.16-initialize-fix.diff
@@ -0,0 +1,10 @@
+--- gpgme/gpgmeplug.c
++++ gpgme/gpgmeplug.c
+@@ -2125,6 +2125,7 @@
+ fprintf( stderr, "startListCertificates( \"%s\", %d )\n", pattern, remote );
+
+ it = xmalloc( sizeof( struct CertIterator ) );
++ memset( &(it->info), 0, sizeof( struct CertificateInfo ) );
+
+ err = gpgme_new (&(it->ctx));
+ /*fprintf( stderr, "2: gpgme returned %d\n", err );*/
diff --git a/app-crypt/cryptplug/files/digest-cryptplug-0.3.16 b/app-crypt/cryptplug/files/digest-cryptplug-0.3.16
new file mode 100644
index 000000000000..60c6f5f19df3
--- /dev/null
+++ b/app-crypt/cryptplug/files/digest-cryptplug-0.3.16
@@ -0,0 +1 @@
+MD5 c4f2bda9446dcca6c5ca31cd35bf2290 cryptplug-0.3.16.tar.gz 224964