summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2007-04-20 23:59:18 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2007-04-20 23:59:18 +0000
commita27abc33becbc6ddda4c803e69ea67fab5a8e0be (patch)
tree1f3832559a26741a76ce9b89ddd4d80d51be482c /app-crypt/aesutil/aesutil-1.0.7.ebuild
parentVersion bump. Includes small bugfixes and 8500/8600 PCI IDs. (diff)
downloadhistorical-a27abc33becbc6ddda4c803e69ea67fab5a8e0be.tar.gz
historical-a27abc33becbc6ddda4c803e69ea67fab5a8e0be.tar.bz2
historical-a27abc33becbc6ddda4c803e69ea67fab5a8e0be.zip
Rename app-crypt/aes-crypt->app-crypt/aesutil, bug#175214
Package-Manager: portage-2.1.2.4
Diffstat (limited to 'app-crypt/aesutil/aesutil-1.0.7.ebuild')
-rw-r--r--app-crypt/aesutil/aesutil-1.0.7.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/aesutil/aesutil-1.0.7.ebuild b/app-crypt/aesutil/aesutil-1.0.7.ebuild
new file mode 100644
index 000000000000..1022799b4ddd
--- /dev/null
+++ b/app-crypt/aesutil/aesutil-1.0.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/aesutil/aesutil-1.0.7.ebuild,v 1.1 2007/04/20 23:59:18 alonbl Exp $
+
+MY_P="${PN/util/}-${PV}"
+DESCRIPTION="Command line program ('aes') to encrypt and decrypt data using the Rijndael algorithm"
+HOMEPAGE="http://my.cubic.ch/users/timtas/aes/"
+SRC_URI="http://my.cubic.ch/users/timtas/aes/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ~ppc-macos sparc x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -e "s:CFLAGS=-g -Wall:CFLAGS=-g -Wall ${CFLAGS}:" Makefile.linux > Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ dobin aes
+ dodoc CHANGES INSTALL README TODO
+}