summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-02-19 18:30:12 +0000
committerMike Frysinger <vapier@gentoo.org>2005-02-19 18:30:12 +0000
commited6d6d0389074e346798c4f7676fb05e333b5543 (patch)
treec83aa8f8831ecc2c7b73f8d3510561d20a94b193 /app-arch
parentold (diff)
downloadhistorical-ed6d6d0389074e346798c4f7676fb05e333b5543.tar.gz
historical-ed6d6d0389074e346798c4f7676fb05e333b5543.tar.bz2
historical-ed6d6d0389074e346798c4f7676fb05e333b5543.zip
rename
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/bzip2-1.0.2-r4.ebuild10
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch27
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch22
3 files changed, 54 insertions, 5 deletions
diff --git a/app-arch/bzip2/bzip2-1.0.2-r4.ebuild b/app-arch/bzip2/bzip2-1.0.2-r4.ebuild
index 356696248d27..550aba49533c 100644
--- a/app-arch/bzip2/bzip2-1.0.2-r4.ebuild
+++ b/app-arch/bzip2/bzip2-1.0.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.2-r4.ebuild,v 1.8 2005/02/11 23:04:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.2-r4.ebuild,v 1.9 2005/02/19 18:30:12 vapier Exp $
inherit toolchain-funcs flag-o-matic
@@ -17,10 +17,10 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-NULL-ptr-check.patch
- epatch ${FILESDIR}/${PV}-makefile-CFLAGS.patch
- epatch ${FILESDIR}/${P}-saneso.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-NULL-ptr-check.patch
+ epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-saneso.patch
sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die
use static && append-flags -static
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch b/app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch
new file mode 100644
index 000000000000..e35080f86db8
--- /dev/null
+++ b/app-arch/bzip2/files/bzip2-1.0.2-NULL-ptr-check.patch
@@ -0,0 +1,27 @@
+Mihai Limbasan writes:
+BZ2_bzclose fails to perform a NULL pointer check before actually
+using the passed BZFILE * argument. The NULL check *is* performed but
+only after the argument is used for the first time, resulting in a
+potential NULL pointer dereference.
+
+http://bugs.gentoo.org/show_bug.cgi?id=75305
+
+Sent upstream but no feedback thus far :(
+diff -Naur bzip2-1.0.2-orig/bzlib.c bzip2-1.0.2/bzlib.c
+--- bzip2-1.0.2-orig/bzlib.c 2002-01-05 02:48:41.000000000 +0200
++++ bzip2-1.0.2/bzlib.c 2004-12-22 15:12:52.824593032 +0200
+@@ -1536,9 +1536,12 @@
+ void BZ_API(BZ2_bzclose) (BZFILE* b)
+ {
+ int bzerr;
+- FILE *fp = ((bzFile *)b)->handle;
+-
++ FILE *fp;
++
+ if (b==NULL) {return;}
++
++ fp = ((bzFile *)b)->handle;
++
+ if(((bzFile*)b)->writing){
+ BZ2_bzWriteClose(&bzerr,b,0,NULL,NULL);
+ if(bzerr != BZ_OK){
diff --git a/app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch b/app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch
new file mode 100644
index 000000000000..bf7d430f9496
--- /dev/null
+++ b/app-arch/bzip2/files/bzip2-1.0.2-makefile-CFLAGS.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2004-12-26 16:30:06.354116536 -0500
++++ Makefile 2004-12-26 16:32:13.617769520 -0500
+@@ -9,7 +9,7 @@
+
+ # Suitably paranoid flags to avoid bugs in gcc-2.7
+ BIGFILES=-D_FILE_OFFSET_BITS=64
+-CFLAGS=-Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
++CFLAGS+=-Wall -Winline -fno-strength-reduce $(BIGFILES)
+
+ # Where you want it installed when you do 'make install'
+ PREFIX=/usr
+--- Makefile-libbz2_so.orig 2004-12-26 16:32:23.972195408 -0500
++++ Makefile-libbz2_so 2004-12-26 16:32:34.835543928 -0500
+@@ -9,7 +9,7 @@
+ SHELL=/bin/sh
+ CC=gcc
+ BIGFILES=-D_FILE_OFFSET_BITS=64
+-CFLAGS=-fpic -fPIC -Wall -Winline -O2 -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
++CFLAGS+=-fpic -fPIC -Wall -Winline -fomit-frame-pointer -fno-strength-reduce $(BIGFILES)
+
+ OBJS= blocksort.o \
+ huffman.o \