summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-20 03:37:00 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-20 03:37:00 +0000
commitadaa947b937c7b2f96de970a1cce4600eb8587e8 (patch)
tree4a121b8a3e3592f064545f17ccd8ad6a29a8eb55 /app-arch
parenttouchup style (diff)
downloadhistorical-adaa947b937c7b2f96de970a1cce4600eb8587e8.tar.gz
historical-adaa947b937c7b2f96de970a1cce4600eb8587e8.tar.bz2
historical-adaa947b937c7b2f96de970a1cce4600eb8587e8.zip
fix by Diego Pettenò to respect custom LDFLAGS #126831
Package-Manager: portage-2.1_pre6-r3
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/unzip/Manifest10
-rw-r--r--app-arch/unzip/unzip-5.52-r1.ebuild13
2 files changed, 18 insertions, 5 deletions
diff --git a/app-arch/unzip/Manifest b/app-arch/unzip/Manifest
index 61354c368321..5ba4798bbf62 100644
--- a/app-arch/unzip/Manifest
+++ b/app-arch/unzip/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 2cfef9ec1b142a17e066868a575ae136 ChangeLog 4192
RMD160 02b05c44dee4e091ef6292108ed7668e0322dce6 ChangeLog 4192
SHA256 beb9e7eb4ff93092c67027045e7b52332ec280ac5a679280a850cd228c329b6d ChangeLog 4192
@@ -28,3 +31,10 @@ SHA256 577551bb1559c115430340b682a57c39fb85e4c97552972702ce197d8c5fda67 unzip-5.
MD5 0106beb499a64c740f57f92911eb5ce7 unzip-5.52.ebuild 1391
RMD160 885022fa91abd1bd4bc32ca6fb2e19b6d849d156 unzip-5.52.ebuild 1391
SHA256 e40926b4b8ebda47d03de7b7b6255d81af1af069aee0323cc8ca8054f91de104 unzip-5.52.ebuild 1391
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.2.2 (GNU/Linux)
+
+iD8DBQFEHiOB2+ySkm8kpY0RAvxuAJ95z7xq6CT5Ot5P+AuJNHiDPkiltQCguxVs
+DShff+1CmTCAcFZLeo7W5Cc=
+=0B/Y
+-----END PGP SIGNATURE-----
diff --git a/app-arch/unzip/unzip-5.52-r1.ebuild b/app-arch/unzip/unzip-5.52-r1.ebuild
index 866ba25dc6bc..e780bc71a739 100644
--- a/app-arch/unzip/unzip-5.52-r1.ebuild
+++ b/app-arch/unzip/unzip-5.52-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.5 2006/02/15 05:29:16 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.52-r1.ebuild,v 1.6 2006/03/20 03:37:00 vapier Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -19,13 +19,15 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-no-exec-stack.patch
- append-lfs-flags #104315
sed -i \
- -e "s:-O3:${CFLAGS}:" \
+ -e 's:-O3:$(CFLAGS):' \
+ -e 's:-O :$(CFLAGS) :' \
-e "s:CC=gcc :CC=$(tc-getCC) :" \
-e "s:LD=gcc :LD=$(tc-getCC) :" \
- -e "s:-O :${CFLAGS} :" \
- -e "s:LF2 = -s:LF2 = :" \
+ -e 's:LF2 = -s:LF2 = :' \
+ -e 's:LF = :LF = $(LDFLAGS) :' \
+ -e 's:SL = :SL = $(LDFLAGS) :' \
+ -e 's:FL = :FL = $(LDFLAGS) :' \
unix/Makefile \
|| die "sed unix/Makefile failed"
}
@@ -41,6 +43,7 @@ src_compile() {
*-darwin*) TARGET=macosx ;;
*) die "Unknown target, you suck" ;;
esac
+ append-lfs-flags #104315
emake -f unix/Makefile ${TARGET} || die "emake failed"
}