summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2004-01-11 13:45:46 +0000
committerMartin Schlemmer <azarah@gentoo.org>2004-01-11 13:45:46 +0000
commite3c567f8d83ae146d6308bd1df2e3474c925e1c2 (patch)
tree5e636dea9a3628ec11903af1825bbc67b5b21124 /app-arch/tar
parentfixed motif dep (diff)
downloadhistorical-e3c567f8d83ae146d6308bd1df2e3474c925e1c2.tar.gz
historical-e3c567f8d83ae146d6308bd1df2e3474c925e1c2.tar.bz2
historical-e3c567f8d83ae146d6308bd1df2e3474c925e1c2.zip
Do not strip './' in path elements, as they are valid, bug #37132. This is
the proper fix from CVS.
Diffstat (limited to 'app-arch/tar')
-rw-r--r--app-arch/tar/Manifest4
-rw-r--r--app-arch/tar/files/digest-tar-1.13.92-r21
-rw-r--r--app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch34
-rw-r--r--app-arch/tar/tar-1.13.92-r2.ebuild68
4 files changed, 105 insertions, 2 deletions
diff --git a/app-arch/tar/Manifest b/app-arch/tar/Manifest
index 110f6f2e7593..57a12c43df5a 100644
--- a/app-arch/tar/Manifest
+++ b/app-arch/tar/Manifest
@@ -1,7 +1,7 @@
MD5 23b3f188b0060fb7423a4f3231ff0cee tar-1.13.92-r1.ebuild 1420
MD5 57e5effc4019741e89ffcc4a3aa5a31c tar-1.13.25-r3.ebuild 1448
-MD5 a23aa9580fc7fd88589e9bd2e55fbf80 ChangeLog 4415
-MD5 f58cfa335aa3973aa4c3a0e4e0a168be tar-1.13.92-r2.ebuild 1484
+MD5 93921ef32db4d51126cfa8809beec876 ChangeLog 4673
+MD5 b4b34ef07d2487364dad02456713798d tar-1.13.92-r2.ebuild 1482
MD5 ebfd134ad54b3a6a08124bef38ecdad6 files/digest-tar-1.13.25-r3 64
MD5 a5f8c5da7a9465ea1978145f3ef0610c files/tar.1 7113
MD5 cb4c8853f6a862e6a16b3901e11c912f files/tar-1.13.92-hardcode-absolute-names-to-on.diff 413
diff --git a/app-arch/tar/files/digest-tar-1.13.92-r2 b/app-arch/tar/files/digest-tar-1.13.92-r2
new file mode 100644
index 000000000000..6590deb15c11
--- /dev/null
+++ b/app-arch/tar/files/digest-tar-1.13.92-r2
@@ -0,0 +1 @@
+MD5 fdfffdd8141a00ea72c16c34b486a00a tar-1.13.92.tar.bz2 1043316
diff --git a/app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch b/app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch
new file mode 100644
index 000000000000..aae49762c6a0
--- /dev/null
+++ b/app-arch/tar/files/tar-1.13.92-dont-strip-dot_slash.patch
@@ -0,0 +1,34 @@
+===================================================================
+RCS file: /cvsroot/tar/cvsroot/tar/tar/src/names.c,v
+retrieving revision 1.36
+retrieving revision 1.37
+diff -u -r1.36 -r1.37
+--- tar/tar/src/names.c 2003/11/17 07:39:33 1.36
++++ tar/tar/src/names.c 2003/12/25 10:19:40 1.37
+@@ -1021,13 +1021,8 @@
+
+ for (p = file_name + prefix_len; *p; )
+ {
+- if (p[0] == '.')
+- {
+- if (p[1] == '.' && (ISSLASH (p[2]) || !p[2]))
+- prefix_len = p + 2 - file_name;
+- else if (ISSLASH (p[1]))
+- prefix_len = p + 1 - file_name;
+- }
++ if (p[0] == '.' && p[1] == '.' && (ISSLASH (p[2]) || !p[2]))
++ prefix_len = p + 2 - file_name;
+
+ do
+ {
+@@ -1072,8 +1067,8 @@
+ };
+ WARN ((0, 0, _(diagnostic[link_target])));
+ }
+-
+- p = ISSLASH (file_name[strlen(file_name)-1]) ? "./" : ".";
++
++ p = ".";
+ }
+
+ return (char *) p;
diff --git a/app-arch/tar/tar-1.13.92-r2.ebuild b/app-arch/tar/tar-1.13.92-r2.ebuild
new file mode 100644
index 000000000000..d8273aed8fd9
--- /dev/null
+++ b/app-arch/tar/tar-1.13.92-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/tar/tar-1.13.92-r2.ebuild,v 1.1 2004/01/11 13:45:33 azarah Exp $
+
+inherit eutils gnuconfig
+
+IUSE="nls static build"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Use this to try make tarballs :)"
+HOMEPAGE="http://www.gnu.org/software/tar/"
+SRC_URI="ftp://alpha.gnu.org/pub/pub/gnu/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64 ~ia64 ~ppc64"
+
+DEPEND="app-arch/gzip
+ app-arch/bzip2
+ app-arch/ncompress"
+
+RDEPEND="nls? ( >=sys-devel/gettext-0.10.35 )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # Do not strip './' in path elements, as they are valid, bug #37132
+ epatch ${FILESDIR}/${P}-dont-strip-dot_slash.patch
+}
+
+src_compile() {
+
+ # Fix configure scripts to support linux-mips targets
+ gnuconfig_update
+
+ econf \
+ --bindir=/bin \
+ --libexecdir=/usr/lib/misc \
+ `use_enable nls` || die
+
+ if [ -z "`use static`" ]
+ then
+ emake || die
+ else
+ emake LDFLAGS=-static || die
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ #FHS 2.1 stuff
+ dodir /usr/sbin
+ cd ${D}
+ mv usr/lib/misc/rmt usr/sbin/rmt.gnu
+ dosym rmt.gnu /usr/sbin/rmt
+ # a nasty yet required symlink:
+ dodir /etc
+ dosym /usr/sbin/rmt /etc/rmt
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ dodoc AUTHORS ChangeLog* COPYING NEWS README* PORTS THANKS
+ doman ${FILESDIR}/tar.1
+ else
+ rm -rf ${D}/usr/share
+ fi
+}