summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-09-26 21:07:41 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-09-26 21:07:41 +0000
commit527aa28d0e9241384b170109c2be41128ac912b5 (patch)
tree45345e79b4dd0220d54d807b8e05d4c20b380baf /app-arch/arc
parentfix deps (diff)
downloadhistorical-527aa28d0e9241384b170109c2be41128ac912b5.tar.gz
historical-527aa28d0e9241384b170109c2be41128ac912b5.tar.bz2
historical-527aa28d0e9241384b170109c2be41128ac912b5.zip
epatch and sed updates, changelog fixes
Diffstat (limited to 'app-arch/arc')
-rw-r--r--app-arch/arc/Manifest2
-rw-r--r--app-arch/arc/arc-521e.ebuild19
2 files changed, 9 insertions, 12 deletions
diff --git a/app-arch/arc/Manifest b/app-arch/arc/Manifest
index 91e1d3c7c261..29f27fa31404 100644
--- a/app-arch/arc/Manifest
+++ b/app-arch/arc/Manifest
@@ -1,4 +1,4 @@
-MD5 3ab486708806f0fb26ffe0cb2bda8227 arc-521e.ebuild 956
MD5 f3ae4c7370959ea4260d00d3d4abe4ed ChangeLog 471
+MD5 cb2841c63d7def1fc18773066f3b19a0 arc-521e.ebuild 838
MD5 11bcb6a067f0bdd2e47b77a6a444b376 files/arc-521e-timeh.patch 516
MD5 d48e9dc9fe0543d956c346d99ce42dd3 files/digest-arc-521e 62
diff --git a/app-arch/arc/arc-521e.ebuild b/app-arch/arc/arc-521e.ebuild
index f812839035c8..abe2b7055885 100644
--- a/app-arch/arc/arc-521e.ebuild
+++ b/app-arch/arc/arc-521e.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/arc-521e.ebuild,v 1.6 2003/02/13 05:52:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arc/arc-521e.ebuild,v 1.7 2003/09/26 21:07:35 aliz Exp $
DESCRIPTION="Create & extract files from DOS .ARC files."
MY_P="${PN}${PV}.pl8"
@@ -17,16 +17,13 @@ S=${WORKDIR}
src_unpack() {
unpack ${A}
- patch -p1 < ${FILESDIR}/${P}-timeh.patch
- cat marc.c | sed -e 's/char \*arctemp2, \*mktemp();/char *arctemp2;/' \
- -e 's/mktemp/mkstemp/g' > marc.c.new
- mv marc.c.new marc.c
- cat arc.c | sed -e 's/\*arctemp2, \*mktemp();/*arctemp2;/g' \
- -e 's/mktemp/mkstemp/g' > arc.c.new
- mv arc.c.new arc.c
-
- cp Makefile Makefile.orig
- sed "s:\$(OPT):${CFLAGS}:" Makefile.orig >Makefile
+ epatch ${FILESDIR}/${P}-timeh.patch
+ sed -i -e 's/char \*arctemp2, \*mktemp();/char *arctemp2;/' \
+ -e 's/mktemp/mkstemp/g' marc.c
+ sed -i -e 's/\*arctemp2, \*mktemp();/*arctemp2;/g' \
+ -e 's/mktemp/mkstemp/g' arc.c
+
+ sed -i "s:\$(OPT):${CFLAGS}:" Makefile
}
src_compile() {