summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-10 02:49:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-10 02:49:12 +0000
commitc406b6d736c1b6137a3aa49b5b0f72c197d586b4 (patch)
treefb5757584adf14b4ad7402c834946d4d7089b8ab /app-admin
parentStable on sparc (diff)
downloadhistorical-c406b6d736c1b6137a3aa49b5b0f72c197d586b4.tar.gz
historical-c406b6d736c1b6137a3aa49b5b0f72c197d586b4.tar.bz2
historical-c406b6d736c1b6137a3aa49b5b0f72c197d586b4.zip
Bug #50847, fix dep on mail stuff.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sxid/ChangeLog7
-rw-r--r--app-admin/sxid/Manifest6
-rw-r--r--app-admin/sxid/files/digest-sxid-4.0.4-r11
-rw-r--r--app-admin/sxid/sxid-4.0.4-r1.ebuild39
4 files changed, 50 insertions, 3 deletions
diff --git a/app-admin/sxid/ChangeLog b/app-admin/sxid/ChangeLog
index da4cddf811ef..1df4d7379062 100644
--- a/app-admin/sxid/ChangeLog
+++ b/app-admin/sxid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sxid
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.12 2005/01/01 11:29:16 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/ChangeLog,v 1.13 2005/03/10 02:49:12 robbat2 Exp $
+
+*sxid-4.0.4-r1 (09 Mar 2005)
+
+ 09 Mar 2005; Robin H. Johnson <robbat2@gentoo.org> +sxid-4.0.4-r1.ebuild:
+ Bug #50847, fix dep on mail stuff.
05 Oct 2004; Pieter Van den Abeele <pvdabeel@gentoo.org> sxid-4.0.2.ebuild,
sxid-4.0.4.ebuild:
diff --git a/app-admin/sxid/Manifest b/app-admin/sxid/Manifest
index aae73d1c0967..99ba55370bd9 100644
--- a/app-admin/sxid/Manifest
+++ b/app-admin/sxid/Manifest
@@ -1,6 +1,8 @@
-MD5 1684865e3226b8dab24c6a3eaf0d0ae7 ChangeLog 1427
-MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 31cab5b34e3cac67e2add6487ee73a5f sxid-4.0.2.ebuild 964
MD5 3aa6e2862553087bf4dfda875a3a8e1f sxid-4.0.4.ebuild 1012
+MD5 4b510b284267d78f5cbbb1d9611726db sxid-4.0.4-r1.ebuild 1021
+MD5 1d956ac44826bdb5734f402eb03ed9d7 ChangeLog 1568
+MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
MD5 d6f1819b2a932dded8bf8054cd14a7ff files/digest-sxid-4.0.2 61
MD5 c073a3f719de056034b9b96ce775a3c3 files/digest-sxid-4.0.4 61
+MD5 c073a3f719de056034b9b96ce775a3c3 files/digest-sxid-4.0.4-r1 61
diff --git a/app-admin/sxid/files/digest-sxid-4.0.4-r1 b/app-admin/sxid/files/digest-sxid-4.0.4-r1
new file mode 100644
index 000000000000..74629f861cf8
--- /dev/null
+++ b/app-admin/sxid/files/digest-sxid-4.0.4-r1
@@ -0,0 +1 @@
+MD5 f85f1bf18651af14efd2b475b87e55b1 sxid_4.0.4.tar.gz 45277
diff --git a/app-admin/sxid/sxid-4.0.4-r1.ebuild b/app-admin/sxid/sxid-4.0.4-r1.ebuild
new file mode 100644
index 000000000000..4b8969081f16
--- /dev/null
+++ b/app-admin/sxid/sxid-4.0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.0.4-r1.ebuild,v 1.1 2005/03/10 02:49:12 robbat2 Exp $
+
+DESCRIPTION="suid, sgid file and directory checking"
+SRC_URI="http://www.phunnypharm.org/pub/sxid/${P/-/_}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/libc
+ mail-client/mailx"
+DEPEND="virtual/libc
+ sys-apps/sed
+ sys-devel/gcc
+ sys-devel/autoconf"
+
+src_compile() {
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ cd source
+ sed -i s/bindir/sbindir/g Makefile.in
+ cd ..
+
+ econf || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README docs/sxid.conf.example docs/sxid.cron.example
+}
+
+pkg_postinst() {
+ einfo "You will need to configure sxid.conf for your system using the manpage and example"
+}