summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2005-07-31 19:10:25 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2005-07-31 19:10:25 +0000
commit6079abe9eb5ae950d75a2ba47945b087783a29d9 (patch)
tree0e1547de5d3e67397f5f703efdba96a0d355a22c /app-admin
parentMarking -ppc64 due to bug #100022. (diff)
downloadhistorical-6079abe9eb5ae950d75a2ba47945b087783a29d9.tar.gz
historical-6079abe9eb5ae950d75a2ba47945b087783a29d9.tar.bz2
historical-6079abe9eb5ae950d75a2ba47945b087783a29d9.zip
Added the latest patch from Debian to resolve bug #55369 and added checks for the right kernel configuration options.
Package-Manager: portage-2.0.51.22-r2
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/longrun/ChangeLog9
-rw-r--r--app-admin/longrun/Manifest5
-rw-r--r--app-admin/longrun/files/digest-longrun-0.9-r22
-rw-r--r--app-admin/longrun/longrun-0.9-r2.ebuild65
-rw-r--r--app-admin/longrun/metadata.xml15
5 files changed, 94 insertions, 2 deletions
diff --git a/app-admin/longrun/ChangeLog b/app-admin/longrun/ChangeLog
index 320c79ef9155..46c4c5aa4922 100644
--- a/app-admin/longrun/ChangeLog
+++ b/app-admin/longrun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/longrun
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/ChangeLog,v 1.9 2005/01/01 11:09:36 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/ChangeLog,v 1.10 2005/07/31 19:10:25 betelgeuse Exp $
+
+*longrun-0.9-r2 (31 Jul 2005)
+
+ 31 Jul 2005; Petteri Räty <betelgeuse@gentoo.org> +metadata.xml,
+ +longrun-0.9-r2.ebuild:
+ Added Debian patches. Resolves bug #55369.
+ Also added checks for the right kernel config.
20 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> longrun-0.9-r1.ebuild:
inherit eutils for epatch; error check
diff --git a/app-admin/longrun/Manifest b/app-admin/longrun/Manifest
index 07e43d0cbf0d..f1cf9879fa9e 100644
--- a/app-admin/longrun/Manifest
+++ b/app-admin/longrun/Manifest
@@ -1,4 +1,7 @@
-MD5 f5afad4c7a372fcc3841c5c09c9f7fb0 ChangeLog 1302
+MD5 3d94bcf5b927c22b25bef55af6501a25 ChangeLog 1523
MD5 d9386ce54e3f6f124a6eb6cd1bf756fd longrun-0.9-r1.ebuild 748
+MD5 9a98fa2d2ab8debf915160e430f11e1e longrun-0.9-r2.ebuild 1632
+MD5 0f5aca3056f50b06e1f68a87bcc0f999 metadata.xml 443
MD5 04159b8a163c87979fbe52e9fef78f21 files/digest-longrun-0.9-r1 63
MD5 b924563938144473dbfc5be5e8f8f025 files/longrun-0.9-r1-debian-gcc-3.diff 32094
+MD5 06f54ba7a3451bfe7d701fb642b64d91 files/digest-longrun-0.9-r2 129
diff --git a/app-admin/longrun/files/digest-longrun-0.9-r2 b/app-admin/longrun/files/digest-longrun-0.9-r2
new file mode 100644
index 000000000000..dbf4a566ce87
--- /dev/null
+++ b/app-admin/longrun/files/digest-longrun-0.9-r2
@@ -0,0 +1,2 @@
+MD5 046a0e3f783d1d50b11a24b309bd40b1 longrun-0.9.tar.bz2 11539
+MD5 acaeaf906e1c1ccc7e61cf3c66d49858 longrun_0.9-17.diff.gz 13897
diff --git a/app-admin/longrun/longrun-0.9-r2.ebuild b/app-admin/longrun/longrun-0.9-r2.ebuild
new file mode 100644
index 000000000000..e2b038ab7b2d
--- /dev/null
+++ b/app-admin/longrun/longrun-0.9-r2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/longrun/longrun-0.9-r2.ebuild,v 1.1 2005/07/31 19:10:25 betelgeuse Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
+HOMEPAGE="http://freshmeat.net/projects/longrun/"
+DEBIAN_PATCH="${PN}_${PV}-17.diff.gz"
+SRC_URI="mirror://kernel/linux/utils/cpu/crusoe/${P}.tar.bz2
+ mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${PN}
+
+CONFIG_CHECK="X86_MSR X86_CPUID"
+
+ERROR_X86_MSR="
+Longrun needs a MSR device to function. Please select
+MSR under Processor type and features. It can be build
+directly into the kernel or as a module.
+"
+
+ERROR_X86_CPUID="
+Longrun needs a CPUID device to function. Please select
+CPUID under Processor type and features. It can be
+build directly into the kernel or as a module.
+"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd ${S}
+ epatch ${DISTDIR}/${DEBIAN_PATCH}
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ dosbin longrun || die "dosbin failed"
+ doman longrun.1
+ dodoc MAKEDEV-cpuid-msr
+}
+
+pkg_postinst() {
+ if linux_chkconfig_module X86_MSR; then
+ einfo "You have compiled MSR as a module."
+ einfo "You need to load it before using Longrun."
+ einfo "The module is called msr."
+ einfo
+ fi
+
+ if linux_chkconfig_module X86_CPUID; then
+ einfo "You have compiled CPUID as a module."
+ einfo "You need to load it before using Longrun."
+ einfo "The module is called cpuid."
+ fi
+}
diff --git a/app-admin/longrun/metadata.xml b/app-admin/longrun/metadata.xml
new file mode 100644
index 000000000000..d4d540f0b029
--- /dev/null
+++ b/app-admin/longrun/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>mobile</herd>
+<maintainer>
+ <email>betelgeuse@gentoo.org</email>
+ <name>Petteri Räty</name>
+</maintainer>
+<longdescription>
+Longrun is a user space utility program for controlling the Longrun
+thermal and power save functionalities found in the processors made
+by Transmeta.
+</longdescription>
+</pkgmetadata>