summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-01-16 11:44:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-01-16 11:44:46 +0000
commit955062fc842c09f99fe9dcf8895cc4fb7751ce2c (patch)
tree229cd03990ef276b8c26dc7a280b25bebeafe465 /app-admin/webmin
parentfiltered out k6-3 flag (diff)
downloadhistorical-955062fc842c09f99fe9dcf8895cc4fb7751ce2c.tar.gz
historical-955062fc842c09f99fe9dcf8895cc4fb7751ce2c.tar.bz2
historical-955062fc842c09f99fe9dcf8895cc4fb7751ce2c.zip
postgresql fixes
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/ChangeLog10
-rw-r--r--app-admin/webmin/files/digest-webmin-1.050-r1 (renamed from app-admin/webmin/files/digest-webmin-1.050)0
-rw-r--r--app-admin/webmin/webmin-1.050-r1.ebuild80
3 files changed, 89 insertions, 1 deletions
diff --git a/app-admin/webmin/ChangeLog b/app-admin/webmin/ChangeLog
index d954891523f1..8a651b6d8114 100644
--- a/app-admin/webmin/ChangeLog
+++ b/app-admin/webmin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/webmin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.10 2003/01/08 03:31:41 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/ChangeLog,v 1.11 2003/01/16 11:44:46 seemant Exp $
+
+*webmin-1.050-r1 (16 Jan 2002)
+
+ 16 Jan 2003; Seemant Kulleen <seemant@gentoo.org> webmin-1.050-r1.ebuild
+ files/digest-webmin-1.050-r1 :
+
+ postgresql config file moved to /var/lib/postgresql/data instad, closing
+ bug #13961 by peter.hermsdorf@web.de (peter hermsdorf)
*webmin-1.050 (16 Dec 2002)
diff --git a/app-admin/webmin/files/digest-webmin-1.050 b/app-admin/webmin/files/digest-webmin-1.050-r1
index 26fed42648d4..26fed42648d4 100644
--- a/app-admin/webmin/files/digest-webmin-1.050
+++ b/app-admin/webmin/files/digest-webmin-1.050-r1
diff --git a/app-admin/webmin/webmin-1.050-r1.ebuild b/app-admin/webmin/webmin-1.050-r1.ebuild
new file mode 100644
index 000000000000..40b7f374f332
--- /dev/null
+++ b/app-admin/webmin/webmin-1.050-r1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.050-r1.ebuild,v 1.1 2003/01/16 11:44:46 seemant Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="http://www.webmin.com/download/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ~ppc sparc"
+
+DEPEND="sys-devel/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ cp ${S}/postgresql/config-gentoo-linux ${T}
+ sed "s:hba_conf=.*:hba_conf=/var/lib/postgresql/data/pg_hba.conf:" \
+ ${T}/config-gentoo-linux > ${S}/postgresql/config-gentoo-linux
+}
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ newexe webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}