summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-04-23 01:29:27 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-04-23 01:29:27 +0000
commitd9a01d9833c30af9b6895abe5b859eb2629e3bad (patch)
treeaded4db2d7f761658474b3e6d46e9133e8adbd04 /app-admin/usermin
parentMore GRP friendly (diff)
downloadhistorical-d9a01d9833c30af9b6895abe5b859eb2629e3bad.tar.gz
historical-d9a01d9833c30af9b6895abe5b859eb2629e3bad.tar.bz2
historical-d9a01d9833c30af9b6895abe5b859eb2629e3bad.zip
further ebuild cleanup. Configuration is included in the ebuild.
Diffstat (limited to 'app-admin/usermin')
-rw-r--r--app-admin/usermin/ChangeLog8
-rw-r--r--app-admin/usermin/files/digest-usermin-1.070-r11
-rw-r--r--app-admin/usermin/usermin-1.070-r1.ebuild83
3 files changed, 91 insertions, 1 deletions
diff --git a/app-admin/usermin/ChangeLog b/app-admin/usermin/ChangeLog
index 885248b60977..d5396a26e1d2 100644
--- a/app-admin/usermin/ChangeLog
+++ b/app-admin/usermin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/usermin
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.22 2004/04/23 00:23:15 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/ChangeLog,v 1.23 2004/04/23 01:29:27 eradicator Exp $
+
+*usermin-1.070-r1 (22 Apr 2004)
+
+ 22 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ usermin-1.070-r1.ebuild:
+ further ebuild cleanup. Configuration is included in the ebuild.
22 Apr 2004; Jeremy Huddleston <eradicator@gentoo.org> usermin-1.000.ebuild,
usermin-1.040.ebuild, usermin-1.051.ebuild, usermin-1.070.ebuild,
diff --git a/app-admin/usermin/files/digest-usermin-1.070-r1 b/app-admin/usermin/files/digest-usermin-1.070-r1
new file mode 100644
index 000000000000..762fae304065
--- /dev/null
+++ b/app-admin/usermin/files/digest-usermin-1.070-r1
@@ -0,0 +1 @@
+MD5 8e557a9c62e721351d71eff3a32ad470 usermin-1.070.tar.gz 2009552
diff --git a/app-admin/usermin/usermin-1.070-r1.ebuild b/app-admin/usermin/usermin-1.070-r1.ebuild
new file mode 100644
index 000000000000..8e9f97bd8222
--- /dev/null
+++ b/app-admin/usermin/usermin-1.070-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/usermin/usermin-1.070-r1.ebuild,v 1.1 2004/04/23 01:29:27 eradicator Exp $
+
+inherit eutils
+
+DESCRIPTION="a web-based user administration interface"
+HOMEPAGE="http://www.webmin.com/index6.html"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+RESTRICT="nomirror"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~ppc"
+IUSE="ssl"
+
+RDEPEND="dev-lang/perl
+ sys-apps/lsof
+ >=sys-apps/sed-4
+ dev-perl/Authen-PAM
+ ssl? ( dev-perl/Net-SSLeay )"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+ # Point to the correct mysql location
+ sed -i "s:/usr/local/mysql:/usr:g" mysql/config
+
+ # Bug #46273... missing config for gentoo
+ cp quota/generic-linux-lib.pl quota/gentoo-linux-lib.p
+}
+
+src_install() {
+ dodir /usr/libexec/usermin
+ cp -a * ${D}/usr/libexec/usermin
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/init.d.usermin usermin
+
+ insinto /etc/pam.d
+ newins ${FILESDIR}/${PN}.pam ${PN}
+
+ dosym ../usr/libexec/usermin /etc/usermin
+}
+
+pkg_postinst() {
+ /etc/init.d/usermin stop >& /dev/null
+ stopstatus=$?
+
+ cd /usr/libexec/usermin
+ config_dir=/etc/usermin
+ var_dir=/var/log/usermin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ use ssl && ssl=1 || ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/usermin/maketemp.pl
+ ./setup.sh > /tmp/.webmin/usermin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/usermin start
+ fi
+
+ einfo "Add usermin to your boot-time services with 'rc-update add usermin'."
+ einfo "Point your web browser to http://localhost:20000 to use usermin."
+}
+
+pkg_prerm() {
+ /etc/init.d/usermin stop >& /dev/null
+}