summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2002-11-11 06:31:26 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2002-11-11 06:31:26 +0000
commit31ad28cb8eb91d39766cdd4789a4d04479ae1c6a (patch)
tree143adf7af11266c516570375ee301069c3e304ae /app-admin/gpsui/gpsui-2.2.ebuild
parentremove extra spaces (diff)
downloadhistorical-31ad28cb8eb91d39766cdd4789a4d04479ae1c6a.tar.gz
historical-31ad28cb8eb91d39766cdd4789a4d04479ae1c6a.tar.bz2
historical-31ad28cb8eb91d39766cdd4789a4d04479ae1c6a.zip
New package (#6837)
Diffstat (limited to 'app-admin/gpsui/gpsui-2.2.ebuild')
-rw-r--r--app-admin/gpsui/gpsui-2.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/gpsui/gpsui-2.2.ebuild b/app-admin/gpsui/gpsui-2.2.ebuild
new file mode 100644
index 000000000000..9393ee4080d6
--- /dev/null
+++ b/app-admin/gpsui/gpsui-2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gpsui/gpsui-2.2.ebuild,v 1.1 2002/11/11 06:31:26 leonardop Exp $
+
+DESCRIPTION="GUI program for managing running processes"
+HOMEPAGE="http://gpsui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls"
+
+MY_P="gpsui"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ =gnome-base/gnome-libs-1.4*
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf=""
+
+ use nls || myconf="--disable-nls"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING README
+}