summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-11-30 11:42:46 +0000
committerMarinus Schraal <foser@gentoo.org>2004-11-30 11:42:46 +0000
commitf12918d8953c3ad3fca06ca6d0120529c5a06654 (patch)
tree85a6e229478906a75a869a6cdf53ae780e75839f /app-admin/gamin/gamin-0.0.18.ebuild
parentpatch to go (diff)
downloadhistorical-f12918d8953c3ad3fca06ca6d0120529c5a06654.tar.gz
historical-f12918d8953c3ad3fca06ca6d0120529c5a06654.tar.bz2
historical-f12918d8953c3ad3fca06ca6d0120529c5a06654.zip
new release
Diffstat (limited to 'app-admin/gamin/gamin-0.0.18.ebuild')
-rw-r--r--app-admin/gamin/gamin-0.0.18.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-admin/gamin/gamin-0.0.18.ebuild b/app-admin/gamin/gamin-0.0.18.ebuild
new file mode 100644
index 000000000000..9e47292074da
--- /dev/null
+++ b/app-admin/gamin/gamin-0.0.18.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.0.18.ebuild,v 1.1 2004/11/30 11:42:46 foser Exp $
+
+inherit eutils
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390"
+IUSE=""
+
+RDEPEND="virtual/libc
+ >=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_compile() {
+
+ # Enable debug for testing the runtime backend patch
+ econf \
+ --enable-inotify \
+ --enable-debug \
+ || die
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO
+
+}