summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 16:02:10 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 16:02:10 +0000
commite51550a9713eda571398a98274b5a5b7b4afe0a6 (patch)
treefa6a49fc1f88e51892ff1dfa5105d32086a06fec /app-accessibility/flite
parentbuh bye virtual/glibc (diff)
downloadhistorical-e51550a9713eda571398a98274b5a5b7b4afe0a6.tar.gz
historical-e51550a9713eda571398a98274b5a5b7b4afe0a6.tar.bz2
historical-e51550a9713eda571398a98274b5a5b7b4afe0a6.zip
love thy libc
Diffstat (limited to 'app-accessibility/flite')
-rw-r--r--app-accessibility/flite/flite-1.2-r1.ebuild14
-rw-r--r--app-accessibility/flite/flite-1.2.ebuild14
2 files changed, 14 insertions, 14 deletions
diff --git a/app-accessibility/flite/flite-1.2-r1.ebuild b/app-accessibility/flite/flite-1.2-r1.ebuild
index b20e81cff2f5..dafa3dfbf10c 100644
--- a/app-accessibility/flite/flite-1.2-r1.ebuild
+++ b/app-accessibility/flite/flite-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2-r1.ebuild,v 1.5 2004/06/24 21:22:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2-r1.ebuild,v 1.6 2004/06/25 15:57:07 vapier Exp $
inherit eutils
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc amd64"
IUSE="static"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S=${WORKDIR}/${P}-release
@@ -30,8 +30,8 @@ src_unpack() {
}
src_compile() {
- local myconf;
- if ! use static; then
+ local myconf
+ if ! use static ; then
myconf="${myconf} --enable-shared"
fi
myconf="${myconf} --with-vox=cmu_us_kal16"
@@ -41,11 +41,11 @@ src_compile() {
emake -j1 || die "Failed compilation"
}
-src_install () {
- dobin bin/*
+src_install() {
+ dobin bin/* || die
dodoc ACKNOWLEDGEMENTS README
- if use static; then
+ if use static ; then
dolib.a lib/*.a
else
for lib in lib/*.so*; do
diff --git a/app-accessibility/flite/flite-1.2.ebuild b/app-accessibility/flite/flite-1.2.ebuild
index 621bd825fb6c..4a751febf267 100644
--- a/app-accessibility/flite/flite-1.2.ebuild
+++ b/app-accessibility/flite/flite-1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2.ebuild,v 1.7 2004/06/24 21:22:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/flite/flite-1.2.ebuild,v 1.8 2004/06/25 15:57:07 vapier Exp $
DESCRIPTION="Flite text to speech engine"
HOMEPAGE="http://www.speech.cs.cmu.edu/flite/index.html"
@@ -12,7 +12,7 @@ SLOT="0"
KEYWORDS="x86 ~ppc ~amd64"
IUSE="static"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S=${WORKDIR}/${P}-release
@@ -26,8 +26,8 @@ src_unpack() {
}
src_compile() {
- local myconf;
- if ! use static; then
+ local myconf
+ if ! use static ; then
myconf="${myconf} --enable-shared"
fi
@@ -36,11 +36,11 @@ src_compile() {
emake -j1 || die "Failed compilation"
}
-src_install () {
- dobin bin/*
+src_install() {
+ dobin bin/* || die
dodoc ACKNOWLEDGEMENTS README
- if use static; then
+ if use static ; then
dolib.a lib/*.a
else
for lib in lib/*.so*; do