summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-02-12 08:02:32 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-02-12 08:02:32 +0000
commitd9d5aeba528864b9715bf7263fa7bd80ad5b4352 (patch)
tree04569410e1514e40fd36c3062e4417aa2f660081 /app-accessibility/dasher
parentforce make -j1 for radiusclient (#81544) (diff)
downloadhistorical-d9d5aeba528864b9715bf7263fa7bd80ad5b4352.tar.gz
historical-d9d5aeba528864b9715bf7263fa7bd80ad5b4352.tar.bz2
historical-d9d5aeba528864b9715bf7263fa7bd80ad5b4352.zip
Patch to fix a broken test in the configure script. See bug #79181.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-accessibility/dasher')
-rw-r--r--app-accessibility/dasher/ChangeLog7
-rw-r--r--app-accessibility/dasher/Manifest5
-rw-r--r--app-accessibility/dasher/dasher-3.2.11.ebuild12
-rw-r--r--app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch25
4 files changed, 44 insertions, 5 deletions
diff --git a/app-accessibility/dasher/ChangeLog b/app-accessibility/dasher/ChangeLog
index b5542235ad34..293ff0259ed9 100644
--- a/app-accessibility/dasher/ChangeLog
+++ b/app-accessibility/dasher/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/dasher
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.26 2005/01/17 20:15:13 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/ChangeLog,v 1.27 2005/02/12 08:02:32 leonardop Exp $
+
+ 12 Feb 2004; Leonardo Boshell <leonardop@gentoo.org> dasher-3.2.11.ebuild,
+ files/dasher-3.2.11-xtst_fix.patch:
+ Added patch to fix a broken library test that can break compilation.
+ Thanks to <s.b.wielinga> for his contribution on bug #79181.
17 Jan 2005; Simon Stelling <blubb@gentoo.org> dasher-3.2.11.ebuild:
stable on amd64
diff --git a/app-accessibility/dasher/Manifest b/app-accessibility/dasher/Manifest
index c2a8ac697cb3..7e5507d67e84 100644
--- a/app-accessibility/dasher/Manifest
+++ b/app-accessibility/dasher/Manifest
@@ -1,7 +1,8 @@
-MD5 dd4199c8b952cf63e2efdd866c8722f6 ChangeLog 3449
+MD5 52f94a30637984fa5b0d1e2d6b3c00ed ChangeLog 3703
MD5 d0726e166c5fbd28bb19ccf0ee103c8d dasher-3.2.10-r1.ebuild 1380
-MD5 792c9df09dbaffa1d147c1feffc92810 dasher-3.2.11.ebuild 1245
+MD5 82312d31f665de3b54f367d21ef4a951 dasher-3.2.11.ebuild 1376
MD5 645aac23c66d08fa6064bdb7c95c76ef metadata.xml 420
MD5 7ca12febbfba2b50f70134394363aa33 files/dasher-3.2.10-glade_fix.patch 548
MD5 c9d895db753a44f74000cd2c73e23781 files/digest-dasher-3.2.10-r1 67
MD5 9c820381411009613600b092eda0ab25 files/digest-dasher-3.2.11 67
+MD5 497bed8a975cd29705cb0e9b41f45d76 files/dasher-3.2.11-xtst_fix.patch 872
diff --git a/app-accessibility/dasher/dasher-3.2.11.ebuild b/app-accessibility/dasher/dasher-3.2.11.ebuild
index 1285b5eb58af..91dee56d3566 100644
--- a/app-accessibility/dasher/dasher-3.2.11.ebuild
+++ b/app-accessibility/dasher/dasher-3.2.11.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-3.2.11.ebuild,v 1.8 2005/01/17 20:15:13 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/dasher/dasher-3.2.11.ebuild,v 1.9 2005/02/12 08:02:32 leonardop Exp $
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A text entry interface, driven by continuous pointing gestures"
HOMEPAGE="http://www.inference.phy.cam.ac.uk/dasher/"
@@ -38,3 +38,11 @@ G2CONF="${G2CONF} $(use_with gnome) $(use_with accessibility a11y) \
$(use_with accessibility speech)"
DOCS="ABOUT-NLS AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fix test phase for the xtst library
+ epatch ${FILESDIR}/${P}-xtst_fix.patch
+}
diff --git a/app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch b/app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch
new file mode 100644
index 000000000000..5ea12bfc2882
--- /dev/null
+++ b/app-accessibility/dasher/files/dasher-3.2.11-xtst_fix.patch
@@ -0,0 +1,25 @@
+diff -ur dasher-3.2.11.orig/configure dasher-3.2.11/configure
+--- dasher-3.2.11.orig/configure 2004-08-02 23:56:24.000000000 +0200
++++ dasher-3.2.11/configure 2005-01-23 09:53:07.000000000 +0100
+@@ -11258,18 +11300,18 @@
+ rm -f conftest.err conftest.$ac_objext \
+ conftest$ac_exeext conftest.$ac_ext
+ done
+- if test "x$XTST_LIBS" = x; then
+- { { echo "$as_me:$LINENO: error: Couldn't find the Xtst library. Check config.log for details" >&5
++ fi
++ if test "x$XTST_LIBS" = x; then
++ { { echo "$as_me:$LINENO: error: Couldn't find the Xtst library. Check config.log for details" >&5
+ echo "$as_me: error: Couldn't find the Xtst library. Check config.log for details" >&2;}
+ { (exit 1); exit 1; }; }
+- else
+- X_LIBS="$X_LIBS $XTST_LIBS"
++ else
++ X_LIBS="$X_LIBS $XTST_LIBS"
+
+ cat >>confdefs.h <<\_ACEOF
+ #define HAVE_XTST 1
+ _ACEOF
+
+- fi
+ fi