summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-07-11 20:49:35 +0000
committerTorsten Veller <tove@gentoo.org>2006-07-11 20:49:35 +0000
commited1de49267f76c3733fc378e1ebd855a9caaf839 (patch)
treefb6d932592a15244b87175ef528a50ea42d32557
parentnew libsdl is in there (diff)
downloadhistorical-ed1de49267f76c3733fc378e1ebd855a9caaf839.tar.gz
historical-ed1de49267f76c3733fc378e1ebd855a9caaf839.tar.bz2
historical-ed1de49267f76c3733fc378e1ebd855a9caaf839.zip
Version bump
Package-Manager: portage-2.1.1_pre2-r6
-rw-r--r--mail-filter/bogofilter/ChangeLog8
-rw-r--r--mail-filter/bogofilter/bogofilter-1.0.3.ebuild73
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-1.0.33
3 files changed, 83 insertions, 1 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 956de3fbf017..e2a93d71a66d 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.53 2006/06/21 21:26:29 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.54 2006/07/11 20:49:35 tove Exp $
+
+*bogofilter-1.0.3 (11 Jul 2006)
+
+ 11 Jul 2006; Torsten Veller <tove@gentoo.org> -bogofilter-1.0.1.ebuild,
+ +bogofilter-1.0.3.ebuild:
+ Version bump.
21 Jun 2006; Daniel Gryniewicz <dang@gentoo.org> bogofilter-1.0.2.ebuild:
Un-keyword amd64. I don't know why repoman succeeded the first time
diff --git a/mail-filter/bogofilter/bogofilter-1.0.3.ebuild b/mail-filter/bogofilter/bogofilter-1.0.3.ebuild
new file mode 100644
index 000000000000..882c4da6d868
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.0.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.0.3.ebuild,v 1.1 2006/07/11 20:49:35 tove Exp $
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+#KEYWORDS="${KEYWORDS} ~arm ~mips" # missing, see bug #74046
+IUSE="gsl berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+src_compile() {
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! use berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Incompatible changes in bogofilter-0.93 and -0.94:"
+ ewarn "Please read the documentation (RELEASE.NOTES)!"
+ ewarn ""
+ einfo ""
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ einfo ""
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-1.0.3 b/mail-filter/bogofilter/files/digest-bogofilter-1.0.3
new file mode 100644
index 000000000000..fcd57f177546
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-1.0.3
@@ -0,0 +1,3 @@
+MD5 f3ccde59a29c1d3519e31fe7e6a9fd29 bogofilter-1.0.3.tar.bz2 778983
+RMD160 d4b6d5329919cefbc4e17168350157b27bb08b9c bogofilter-1.0.3.tar.bz2 778983
+SHA256 71d9f184ceba98233543a7f620eed6fdd447c38541f7e46a99e2c991f38c5e95 bogofilter-1.0.3.tar.bz2 778983