summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-07-19 12:44:30 +0000
committerMarinus Schraal <foser@gentoo.org>2004-07-19 12:44:30 +0000
commitc0313d252f6dab18ac4b3cc6470023ed2f90f238 (patch)
tree1c2e62d3756c6c7125e0e78457b11f61e2ba9c6e
parentskkserv, flim, semi, w3m, ruby (diff)
downloadhistorical-c0313d252f6dab18ac4b3cc6470023ed2f90f238.tar.gz
historical-c0313d252f6dab18ac4b3cc6470023ed2f90f238.tar.bz2
historical-c0313d252f6dab18ac4b3cc6470023ed2f90f238.zip
add patch to fix sound events issue
-rw-r--r--gnome-base/libgnome/ChangeLog7
-rw-r--r--gnome-base/libgnome/Manifest5
-rw-r--r--gnome-base/libgnome/files/digest-libgnome-2.6.1.1-r11
-rw-r--r--gnome-base/libgnome/files/libgnome-2.6.1.1-fix_sound.patch12
-rw-r--r--gnome-base/libgnome/libgnome-2.6.1.1-r1.ebuild39
5 files changed, 62 insertions, 2 deletions
diff --git a/gnome-base/libgnome/ChangeLog b/gnome-base/libgnome/ChangeLog
index 04c78fb905ff..40b8d4731e2b 100644
--- a/gnome-base/libgnome/ChangeLog
+++ b/gnome-base/libgnome/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/libgnome
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/ChangeLog,v 1.53 2004/07/04 10:52:05 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/ChangeLog,v 1.54 2004/07/19 12:44:30 foser Exp $
+
+*libgnome-2.6.1.1-r1 (19 Jul 2004)
+
+ 19 Jul 2004; foser <foser@gentoo.org> libgnome-2.6.1.1-r1.ebuild, files/libgnome-2.6.1.1-fix_sounds.patch :
+ Add patch to fix sound events (#50700)
04 Jul 2004; Bryan Østergaard <kloeri@gentoo.org> libgnome-2.6.0.ebuild:
Stable on alpha.
diff --git a/gnome-base/libgnome/Manifest b/gnome-base/libgnome/Manifest
index f0b2b46046e8..9aa6c0cc842b 100644
--- a/gnome-base/libgnome/Manifest
+++ b/gnome-base/libgnome/Manifest
@@ -1,8 +1,11 @@
MD5 c5ca25f14e75b9fcaf16d097f5b5ff29 libgnome-2.4.0.ebuild 818
MD5 94aa184fd8d10fea661dc45e7d631cbe libgnome-2.6.1.1.ebuild 826
MD5 06e14e15235f634153d1d11cd9e4e3b6 libgnome-2.6.0.ebuild 813
-MD5 83d83dbe4b682d3215d8ad0a490700fe ChangeLog 5845
+MD5 e8ee4ab9592dac34fbe350837411c9ce libgnome-2.6.1.1-r1.ebuild 921
+MD5 24ec48d8965960cfafd4a02dec962ec4 ChangeLog 6033
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 855dcd3c74ed050bee4e7f8d50a3b870 files/digest-libgnome-2.4.0 67
MD5 db85dc1051fbaabe3ef0b73fa8c6f13c files/digest-libgnome-2.6.0 68
+MD5 971c1f5de6aa1275e6e49d2026058beb files/digest-libgnome-2.6.1.1-r1 70
MD5 971c1f5de6aa1275e6e49d2026058beb files/digest-libgnome-2.6.1.1 70
+MD5 5c0b401f19aeb078f2fb6d04bbb545c0 files/libgnome-2.6.1.1-fix_sound.patch 515
diff --git a/gnome-base/libgnome/files/digest-libgnome-2.6.1.1-r1 b/gnome-base/libgnome/files/digest-libgnome-2.6.1.1-r1
new file mode 100644
index 000000000000..19b3cd9ba40f
--- /dev/null
+++ b/gnome-base/libgnome/files/digest-libgnome-2.6.1.1-r1
@@ -0,0 +1 @@
+MD5 8fb8d073987cb4c5d9bfe577550d11c2 libgnome-2.6.1.1.tar.bz2 1093492
diff --git a/gnome-base/libgnome/files/libgnome-2.6.1.1-fix_sound.patch b/gnome-base/libgnome/files/libgnome-2.6.1.1-fix_sound.patch
new file mode 100644
index 000000000000..7f16442f8567
--- /dev/null
+++ b/gnome-base/libgnome/files/libgnome-2.6.1.1-fix_sound.patch
@@ -0,0 +1,12 @@
+diff -uNr libgnome-2.6.1.1/libgnome/gnome-program.c libgnome-2.6.1.1.patched/libgnome/gnome-program.c
+--- libgnome-2.6.1.1/libgnome/gnome-program.c 2004-04-18 20:57:13.000000000 +0200
++++ libgnome-2.6.1.1.patched/libgnome/gnome-program.c 2004-07-19 14:19:34.378750928 +0200
+@@ -602,6 +602,8 @@
+
+ program->_priv->state = APP_CREATE_DONE;
+
++ program->_priv->prop_enable_sound = TRUE;
++
+ for (i = 0; i < program_modules->len; i++) {
+ GnomeModuleInfo *a_module = g_ptr_array_index (program_modules, i);
+
diff --git a/gnome-base/libgnome/libgnome-2.6.1.1-r1.ebuild b/gnome-base/libgnome/libgnome-2.6.1.1-r1.ebuild
new file mode 100644
index 000000000000..00ff470abdf8
--- /dev/null
+++ b/gnome-base/libgnome/libgnome-2.6.1.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnome/libgnome-2.6.1.1-r1.ebuild,v 1.1 2004/07/19 12:44:30 foser Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Essential Gnome Libraries"
+HOMEPAGE="http://www.gnome.org/"
+
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips ~ppc64"
+LICENSE="GPL-2 LGPL-2"
+
+RDEPEND=">=dev-libs/glib-2.0.3
+ >=gnome-base/gconf-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2.5.3
+ >=media-sound/esound-0.2.26
+ >=media-libs/audiofile-0.2.3
+ >=dev-libs/popt-1.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.6 )"
+
+G2CONF="${G2CONF} --disable-schemas-install "
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix_sound.patch
+
+}