summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-28 10:01:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-28 10:01:11 +0000
commitbe06fbc0556ce639686737d7e133749f7716d4ba (patch)
tree5c342ca11895a6b66ce42cd94e64440c3bf9e79a
parentFixed hppa patch && stable on hppa. (diff)
downloadhistorical-be06fbc0556ce639686737d7e133749f7716d4ba.tar.gz
historical-be06fbc0556ce639686737d7e133749f7716d4ba.tar.bz2
historical-be06fbc0556ce639686737d7e133749f7716d4ba.zip
New upstream version. Add manpages. Build filelist-order with large file support. Code cleanup.
Package-Manager: portage-2.0.51.19
-rw-r--r--sys-apps/readahead-list/ChangeLog9
-rw-r--r--sys-apps/readahead-list/Manifest4
-rw-r--r--sys-apps/readahead-list/files/digest-readahead-list-0.20050328.01421
-rw-r--r--sys-apps/readahead-list/readahead-list-0.20050328.0142.ebuild52
4 files changed, 64 insertions, 2 deletions
diff --git a/sys-apps/readahead-list/ChangeLog b/sys-apps/readahead-list/ChangeLog
index 28b152b001bc..a9a78df4ba8c 100644
--- a/sys-apps/readahead-list/ChangeLog
+++ b/sys-apps/readahead-list/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-apps/readahead-list
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/readahead-list/ChangeLog,v 1.2 2005/03/23 08:33:12 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/readahead-list/ChangeLog,v 1.3 2005/03/28 10:01:11 robbat2 Exp $
+
+*readahead-list-0.20050328.0142 (28 Mar 2005)
+
+ 28 Mar 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +readahead-list-0.20050328.0142.ebuild:
+ New upstream version. Add manpages. Build filelist-order with large file
+ support. Code cleanup.
*readahead-list-0.20050323.0658 (23 Mar 2005)
diff --git a/sys-apps/readahead-list/Manifest b/sys-apps/readahead-list/Manifest
index 45346b2eb32f..e64c6bf4301c 100644
--- a/sys-apps/readahead-list/Manifest
+++ b/sys-apps/readahead-list/Manifest
@@ -1,6 +1,8 @@
MD5 98d39a3e2ac8773ea9a71fd51e936fd0 readahead-list-0.20050320.2320.ebuild 1081
+MD5 7e1be662d55b762fadd332b647ebfa4b readahead-list-0.20050328.0142.ebuild 1472
MD5 80a2995b54eef91e80d5a2d9903d398b readahead-list-0.20050323.0658.ebuild 1313
-MD5 317332af9dd39fee150ca090168a4739 ChangeLog 746
+MD5 0f3a19f6efe7be167ea937f9d2537eb8 ChangeLog 989
MD5 9fed7d835204a85cc1da8ae9b3a81e10 metadata.xml 306
MD5 a30a550753bc067a2cf24fd8f2c106ba files/digest-readahead-list-0.20050320.2320 82
MD5 12838347caea6c623cfa189d8eeca91c files/digest-readahead-list-0.20050323.0658 83
+MD5 705c1a581218476779280f4af399247c files/digest-readahead-list-0.20050328.0142 83
diff --git a/sys-apps/readahead-list/files/digest-readahead-list-0.20050328.0142 b/sys-apps/readahead-list/files/digest-readahead-list-0.20050328.0142
new file mode 100644
index 000000000000..a5cec407acaa
--- /dev/null
+++ b/sys-apps/readahead-list/files/digest-readahead-list-0.20050328.0142
@@ -0,0 +1 @@
+MD5 ef10ce3e1ccb660b671252ad5d0af5bd readahead-list-0.20050328.0142.tar.bz2 106429
diff --git a/sys-apps/readahead-list/readahead-list-0.20050328.0142.ebuild b/sys-apps/readahead-list/readahead-list-0.20050328.0142.ebuild
new file mode 100644
index 000000000000..63fe4106ffb3
--- /dev/null
+++ b/sys-apps/readahead-list/readahead-list-0.20050328.0142.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/readahead-list/readahead-list-0.20050328.0142.ebuild,v 1.1 2005/03/28 10:01:11 robbat2 Exp $
+
+DESCRIPTION="Preloads files into the page cache to accelerate program loading."
+
+HOMEPAGE="http://www.orbis-terrarum.net"
+SRC_URI="${HOMEPAGE}/custom-software/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+# I'm not entirely certain about this
+# need to check if other libc variants provide readahead(2)
+RDEPEND="virtual/libc"
+# the blocked headers are broken
+# they don't compile properly!
+DEPEND="${RDEPEND}
+ virtual/os-headers
+ !=sys-kernel/linux26-headers-2.6.8.1*"
+
+src_compile() {
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # init scripts
+ cd ${S}/contrib/init/gentoo/
+ newinitd init.d-readahead-list readahead-list
+ newconfd conf.d-readahead-list readahead-list
+
+ # default config
+ insinto /etc/readahead-list
+ cd ${S}/contrib/data
+ newins readahead.runlevel-default.list runlevel-default
+ newins readahead.runlevel-boot.list runlevel-boot
+ newins readahead._sbin_rc.list exec_sbin_rc
+
+ # docs
+ cd ${S}
+ dodoc README
+ if use doc; then
+ docinto scripts
+ dodoc contrib/scripts/*
+ fi
+ # clean up a bit
+ find ${D}/usr/share/doc/${PF}/ -type f -name 'Makefile*' -exec rm -f \{} \;
+}