summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2004-06-05 17:42:14 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2004-06-05 17:42:14 +0000
commitb7a20133f427958c590608d5cce4802a86043380 (patch)
treea4aeb5f993293c66e4a3e9283e2113680ab8c6e7
parentnew cpan version (diff)
downloadhistorical-b7a20133f427958c590608d5cce4802a86043380.tar.gz
historical-b7a20133f427958c590608d5cce4802a86043380.tar.bz2
historical-b7a20133f427958c590608d5cce4802a86043380.zip
Using new version of the python extension with much better documentation.
-rw-r--r--app-sci/snns/ChangeLog7
-rw-r--r--app-sci/snns/Manifest4
-rw-r--r--app-sci/snns/files/digest-snns-4.2-r64
-rw-r--r--app-sci/snns/snns-4.2-r6.ebuild106
4 files changed, 119 insertions, 2 deletions
diff --git a/app-sci/snns/ChangeLog b/app-sci/snns/ChangeLog
index bcf6106a9207..0fb020f23ffb 100644
--- a/app-sci/snns/ChangeLog
+++ b/app-sci/snns/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-sci/snns
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.13 2004/06/02 13:09:37 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/ChangeLog,v 1.14 2004/06/05 17:42:14 phosphan Exp $
+
+*snns-4.2-r6 (05 Jun 2004)
+
+ 05 Jun 2004; Patrick Kursawe <phosphan@gentoo.org> snns-4.2-r6.ebuild:
+ Documentation of the python extension is in a usable state now.
02 Jun 2004; Aron Griffis <agriffis@gentoo.org> snns-4.2-r4.ebuild:
Fix use invocation
diff --git a/app-sci/snns/Manifest b/app-sci/snns/Manifest
index fb9a5a3a4f43..bb3f902d1292 100644
--- a/app-sci/snns/Manifest
+++ b/app-sci/snns/Manifest
@@ -1,6 +1,8 @@
MD5 f0132d8117833a97ac65f3fe01d6b48c snns-4.2-r5.ebuild 2527
MD5 c40811a6fe256f6238814e4a66f95535 snns-4.2-r4.ebuild 1640
-MD5 4bbfa4a15349cda91fe96d4057e2ca8d ChangeLog 1825
+MD5 629cdc1baf2ba219788be0bc27ce05bc snns-4.2-r6.ebuild 2527
+MD5 c1bd9e80263c335b6fdcd935f6d66e51 ChangeLog 1993
MD5 c000c0728c9136f1b54cbc3a5fc07644 metadata.xml 220
MD5 409a7ed863845a91ab923aee9873a062 files/digest-snns-4.2-r4 196
MD5 228f8f47f6f6361ea57cd4f4f9b74d9d files/digest-snns-4.2-r5 262
+MD5 13bc6c016dc3aa799a25598dead6346e files/digest-snns-4.2-r6 262
diff --git a/app-sci/snns/files/digest-snns-4.2-r6 b/app-sci/snns/files/digest-snns-4.2-r6
new file mode 100644
index 000000000000..d3e961a5e2c2
--- /dev/null
+++ b/app-sci/snns/files/digest-snns-4.2-r6
@@ -0,0 +1,4 @@
+MD5 4609dfd61714bfbb0842d4e8e905e584 SNNSv4.2.tar.gz 2170375
+MD5 73a999a41bb91a4f8b5653ddddfcc527 snns-4.2-20040227.patch.gz 55476
+MD5 e91242fdc43877013ade3b5f2213659a SNNSv4.2.Manual.pdf 2103861
+MD5 fd63676eabeab8c633b176c01cbf8d44 PySNNS-20040605.tar.gz 20158
diff --git a/app-sci/snns/snns-4.2-r6.ebuild b/app-sci/snns/snns-4.2-r6.ebuild
new file mode 100644
index 000000000000..7cfb412d5096
--- /dev/null
+++ b/app-sci/snns/snns-4.2-r6.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/snns/snns-4.2-r6.ebuild,v 1.1 2004/06/05 17:42:14 phosphan Exp $
+
+inherit eutils python
+
+MY_P="SNNSv${PV}"
+MYPATCH="${P}-20040227"
+MYPYTHONEXT="PySNNS-20040605"
+
+DESCRIPTION="Stuttgart Neural Network Simulator"
+HOMEPAGE="http://www-ra.informatik.uni-tuebingen.de/SNNS/"
+SRC_URI="http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.tar.gz
+ http://download.berlios.de/snns-dev/${MYPATCH}.patch.gz
+ doc? ( http://www-ra.informatik.uni-tuebingen.de/downloads/SNNS/${MY_P}.Manual.pdf )
+ python? ( http://download.berlios.de/snns-dev/${MYPYTHONEXT}.tar.gz )"
+
+LICENSE="SNNS-${PV}"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE="X doc python"
+
+DEPEND="X? ( virtual/x11
+ x11-libs/Xaw3d )
+ >=sys-apps/sed-4
+ python? ( >=dev-lang/python-2.3 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ unpack ${MYPATCH}.patch.gz
+ epatch ${MYPATCH}.patch
+ use python && unpack ${MYPYTHONEXT}.tar.gz
+}
+
+src_compile() {
+ local myconf="--enable-global"
+ local compileopts="compile-kernel compile-tools"
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ compileopts="${compileopts} compile-xgui"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake ${compileopts} || die "emake failed"
+
+ if use python; then
+ cd python
+ python setup.py build || die "could not build python extension"
+ fi
+}
+
+src_install() {
+ for file in `find tools -type f -perm +100`; do
+ dobin $file
+ done
+
+ if use X; then
+ newbin xgui/sources/xgui snns
+
+ dodir /etc/env.d
+ echo XGUILOADPATH=/usr/share/doc/${PF}/ > ${D}/etc/env.d/99snns
+
+ insinto /usr/share/doc/${PF}
+ doins default.cfg help.hdoc
+ fi
+
+ if use python; then
+ cd python
+ python setup.py install --prefix=${D}/usr || die "could not install python module"
+ cp -a examples ${D}/usr/share/doc/${PF}/python-examples
+ chmod +x ${D}/usr/share/doc/${PF}/python-examples/*.py
+ newdoc README README.python
+ cd ${S}
+ fi
+
+ insinto /usr/share/doc/${PF}
+ use doc && doins ${DISTDIR}/${MY_P}.Manual.pdf
+
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+
+ doman man/man*/*
+}
+
+pkg_postinst() {
+ if use python; then
+ einfo "Pre-compiling Python module"
+ python_version
+ for file in __init__.py util.py; do
+ python_mod_compile \
+ ${ROOT}/usr/lib/python${PYVER}/site-packages/snns/${file}
+ done
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ einfo "Cleaning up python stuff"
+ python_mod_cleanup
+ fi
+}