summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2001-10-21 16:21:44 +0000
committerAron Griffis <agriffis@gentoo.org>2001-10-21 16:21:44 +0000
commit9289d7f6990b93404b29573af1d2133236452a17 (patch)
treef4f07b1c2fc262b3daa764360b458360396fee3e
parentfixup (diff)
downloadhistorical-9289d7f6990b93404b29573af1d2133236452a17.tar.gz
historical-9289d7f6990b93404b29573af1d2133236452a17.tar.bz2
historical-9289d7f6990b93404b29573af1d2133236452a17.zip
Fixup tabs.
-rw-r--r--app-editors/vim/vim-6.0-r2.ebuild296
1 files changed, 148 insertions, 148 deletions
diff --git a/app-editors/vim/vim-6.0-r2.ebuild b/app-editors/vim/vim-6.0-r2.ebuild
index b40a6d0eb692..93a05095c3dc 100644
--- a/app-editors/vim/vim-6.0-r2.ebuild
+++ b/app-editors/vim/vim-6.0-r2.ebuild
@@ -1,23 +1,23 @@
# Copyright 2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Authors Ben Beuchler <insyte@mazer.squad51.net>
-# and Aron Griffis <agriffis@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.0-r2.ebuild,v 1.1 2001/10/17 13:25:55 agriffis Exp $
+# and Aron Griffis <agriffis@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.0-r2.ebuild,v 1.2 2001/10/21 16:21:44 agriffis Exp $
# Please name the ebuild as follows. If this is followed, there
# should be no need to modify this ebuild when the Vim version is
-# updated. (Yes it's overkill, but it was fun!)
+# updated. (Yes it's overkill, but it was fun!)
#
-# vim-6.0, when 6.0 is finally released
-# vim-6.0_pre9, where 9 = (i), for vim-6.0i
-# vim-6.0_pre47, where 47 = 26(a) + 21(u), for vim-6.0au
-# vim-6.0_pre72, where 72 = 52(b) + 20(t), for vim-6.0bt
+# vim-6.0, when 6.0 is finally released
+# vim-6.0_pre9, where 9 = (i), for vim-6.0i
+# vim-6.0_pre47, where 47 = 26(a) + 21(u), for vim-6.0au
+# vim-6.0_pre72, where 72 = 52(b) + 20(t), for vim-6.0bt
#
# Quick reference:
-# a=1 e=5 i=9 m=13 q=17 u=21 y=25
-# b=2 f=6 j=10 n=14 r=18 v=22 z=26
-# c=3 g=7 k=11 o=15 s=19 w=23 aa=27
-# d=4 h=8 l=12 p=16 t=20 x=24 ab=28 (etc.)
+# a=1 e=5 i=9 m=13 q=17 u=21 y=25
+# b=2 f=6 j=10 n=14 r=18 v=22 z=26
+# c=3 g=7 k=11 o=15 s=19 w=23 aa=27
+# d=4 h=8 l=12 p=16 t=20 x=24 ab=28 (etc.)
#
# (08 Sep 2001 agriffis)
@@ -25,61 +25,61 @@
vim_version="${PV%_pre*}"
vim_pre="${PV##*_pre}"
if [ "$vim_version" = "$vim_pre" ]; then
- # Final releases prior to 6.0 include a dash and decimal point in
- # the directory name
- if [ "${vim_version%%.*}" -lt 6 ]; then
- S="$WORKDIR/vim-$vim_version"
- else
- S="$WORKDIR/vim${vim_version//.}"
- fi
- vim_letters=
- A="vim-$vim_version.tar.bz2"
- SRC_URI="ftp://ftp.us.vim.org/pub/vim/unix/$A
- ftp://ftp.vim.org/pub/vim/unix/$A"
+ # Final releases prior to 6.0 include a dash and decimal point in
+ # the directory name
+ if [ "${vim_version%%.*}" -lt 6 ]; then
+ S="$WORKDIR/vim-$vim_version"
+ else
+ S="$WORKDIR/vim${vim_version//.}"
+ fi
+ vim_letters=
+ A="vim-$vim_version.tar.bz2"
+ SRC_URI="ftp://ftp.us.vim.org/pub/vim/unix/$A
+ ftp://ftp.vim.org/pub/vim/unix/$A"
elif [ "$vim_pre" -lt 27 ]; then
- # Handle (prerelease) versions with one trailing letter
- vim_letters=`echo $vim_pre | awk '{printf "%c", $0+96}'`
- S="$WORKDIR/vim${vim_version//.}$vim_letters"
- A="vim-$vim_version$vim_letters.tar.bz2"
- SRC_URI="ftp://ftp.us.vim.org/pub/vim/unreleased/unix/$A
- ftp://ftp.vim.org/pub/vim/unreleased/unix/$A"
+ # Handle (prerelease) versions with one trailing letter
+ vim_letters=`echo $vim_pre | awk '{printf "%c", $0+96}'`
+ S="$WORKDIR/vim${vim_version//.}$vim_letters"
+ A="vim-$vim_version$vim_letters.tar.bz2"
+ SRC_URI="ftp://ftp.us.vim.org/pub/vim/unreleased/unix/$A
+ ftp://ftp.vim.org/pub/vim/unreleased/unix/$A"
elif [ "$vim_pre" -lt 703 ]; then
- # Handle (prerelease) versions with two trailing letters
- vim_letters=`echo $vim_pre | awk '{printf "%c%c", $0/26+96, $0%26+96}'`
- S="$WORKDIR/vim${vim_version//.}$vim_letters"
- A="vim-$vim_version$vim_letters.tar.bz2"
- SRC_URI="ftp://ftp.us.vim.org/pub/vim/unreleased/unix/$A
- ftp://ftp.vim.org/pub/vim/unreleased/unix/$A"
+ # Handle (prerelease) versions with two trailing letters
+ vim_letters=`echo $vim_pre | awk '{printf "%c%c", $0/26+96, $0%26+96}'`
+ S="$WORKDIR/vim${vim_version//.}$vim_letters"
+ A="vim-$vim_version$vim_letters.tar.bz2"
+ SRC_URI="ftp://ftp.us.vim.org/pub/vim/unreleased/unix/$A
+ ftp://ftp.vim.org/pub/vim/unreleased/unix/$A"
else
- die "Eek! I don't know how to interpret the version!"
+ die "Eek! I don't know how to interpret the version!"
fi
# Add in 6.0 patches
#
# For some reason this doesn't work. Portage never fetches these
-# patches. For the moment I'm putting them in vim/files until this is
+# patches. For the moment I'm putting them in vim/files until this is
# resolved.
#
#if [ "$PV" = 6.0 ]; then
-# SRC_URI="$SRC_URI
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.001
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.002
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.003
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.004
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.005
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.006
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.007
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.010
-# ftp://ftp.us.vim.org/pub/vim/patches/6.0.011
-# ftp://ftp.vim.org/pub/vim/patches/6.0.001
-# ftp://ftp.vim.org/pub/vim/patches/6.0.002
-# ftp://ftp.vim.org/pub/vim/patches/6.0.003
-# ftp://ftp.vim.org/pub/vim/patches/6.0.004
-# ftp://ftp.vim.org/pub/vim/patches/6.0.005
-# ftp://ftp.vim.org/pub/vim/patches/6.0.006
-# ftp://ftp.vim.org/pub/vim/patches/6.0.007
-# ftp://ftp.vim.org/pub/vim/patches/6.0.010
-# ftp://ftp.vim.org/pub/vim/patches/6.0.011"
+# SRC_URI="$SRC_URI
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.001
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.002
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.003
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.004
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.005
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.006
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.007
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.010
+# ftp://ftp.us.vim.org/pub/vim/patches/6.0.011
+# ftp://ftp.vim.org/pub/vim/patches/6.0.001
+# ftp://ftp.vim.org/pub/vim/patches/6.0.002
+# ftp://ftp.vim.org/pub/vim/patches/6.0.003
+# ftp://ftp.vim.org/pub/vim/patches/6.0.004
+# ftp://ftp.vim.org/pub/vim/patches/6.0.005
+# ftp://ftp.vim.org/pub/vim/patches/6.0.006
+# ftp://ftp.vim.org/pub/vim/patches/6.0.007
+# ftp://ftp.vim.org/pub/vim/patches/6.0.010
+# ftp://ftp.vim.org/pub/vim/patches/6.0.011"
#fi
DESCRIPTION="Vi IMproved! ($vim_version$vim_letters)"
@@ -89,112 +89,112 @@ HOMEPAGE="http://www.vim.org/"
# When you --enable-tclinterp flag, then the following command never
# returns:
#
-# VIMINIT='let OS = system("uname -s")' vim
+# VIMINIT='let OS = system("uname -s")' vim
#
# Please don't re-enable the tclinterp flag without verifying first
-# that the above works. Thanks. (08 Sep 2001 agriffis)
+# that the above works. Thanks. (08 Sep 2001 agriffis)
DEPEND="$guidep
- virtual/glibc
- >=sys-libs/ncurses-5.2-r2
- dev-util/cscope
- gpm? ( >=sys-libs/gpm-1.19.3 )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
- gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
- X? ( x11-base/xfree )
- perl? ( sys-devel/perl )
- python? ( dev-lang/python )
- ruby? ( >=dev-lang/ruby-1.6.4 )"
-# tcltk? ( dev-lang/tcl-tk )"
+ virtual/glibc
+ >=sys-libs/ncurses-5.2-r2
+ dev-util/cscope
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ gtk? ( >=x11-libs/gtk+-1.2.10-r4 )
+ X? ( x11-base/xfree )
+ perl? ( sys-devel/perl )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.6.4 )"
+# tcltk? ( dev-lang/tcl-tk )"
src_unpack() {
- unpack $A
- # Fixup a script to use awk instead of nawk
- cd $S/runtime/tools
- mv mve.awk mve.awk.old
- ( read l; echo "#!/usr/bin/awk -f"; cat ) <mve.awk.old >mve.awk
- # 6.0 filetype patch to recognize ebuilds
- if [ "$PV" = 6.0 ]; then
- cd $S/runtime
- patch -p0 < $FILESDIR/ebuild.patch || die "Error applying ebuild.patch"
- fi
- # Apply other patches, if appropriate
- local patches=`echo $FILESDIR/$PV.[0-9][0-9][0-9]`
- case "$patches" in
- *\])
- break # globbing didn't work; no patches available
- ;;
- *)
- cd $S
- for a in $patches; do
- patch -p0 < $a || die "Error applying patch ${a##*/}"
- done
- ;;
- esac
+ unpack $A
+ # Fixup a script to use awk instead of nawk
+ cd $S/runtime/tools
+ mv mve.awk mve.awk.old
+ ( read l; echo "#!/usr/bin/awk -f"; cat ) <mve.awk.old >mve.awk
+ # 6.0 filetype patch to recognize ebuilds
+ if [ "$PV" = 6.0 ]; then
+ cd $S/runtime
+ patch -p0 < $FILESDIR/ebuild.patch || die "Error applying ebuild.patch"
+ fi
+ # Apply other patches, if appropriate
+ local patches=`echo $FILESDIR/$PV.[0-9][0-9][0-9]`
+ case "$patches" in
+ *\])
+ break # globbing didn't work; no patches available
+ ;;
+ *)
+ cd $S
+ for a in $patches; do
+ patch -p0 < $a || die "Error applying patch ${a##*/}"
+ done
+ ;;
+ esac
}
src_compile() {
- local myconf
- use nls || myconf="--disable-nls"
- use gpm || myconf="$myconf --disable-gpm"
- use perl && myconf="$myconf --enable-perlinterp"
- use python && myconf="$myconf --enable-pythoninterp"
- use ruby && myconf="$myconf --enable-rubyinterp"
+ local myconf
+ use nls || myconf="--disable-nls"
+ use gpm || myconf="$myconf --disable-gpm"
+ use perl && myconf="$myconf --enable-perlinterp"
+ use python && myconf="$myconf --enable-pythoninterp"
+ use ruby && myconf="$myconf --enable-rubyinterp"
# tclinterp is BROKEN. See note above DEPEND=
-# use tcltk && myconf="$myconf --enable-tclinterp"
+# use tcltk && myconf="$myconf --enable-tclinterp"
- #
- # First, build a gui version, this will install as /usr/bin/gvim
- #
- if use gnome; then
- guiconf="--enable-gui=gnome --with-x"
- elif use gtk; then
- guiconf="--enable-gui=gtk --with-x"
- elif use X; then
- guiconf="--enable-gui=athena --with-x"
- else
- # No gui version will be built
- guiconf=""
- fi
- if [ -n "$guiconf" ]; then
+ #
+ # First, build a gui version, this will install as /usr/bin/gvim
+ #
+ if use gnome; then
+ guiconf="--enable-gui=gnome --with-x"
+ elif use gtk; then
+ guiconf="--enable-gui=gtk --with-x"
+ elif use X; then
+ guiconf="--enable-gui=athena --with-x"
+ else
+ # No gui version will be built
+ guiconf=""
+ fi
+ if [ -n "$guiconf" ]; then
+ ./configure \
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --enable-max-features --enable-cscope $myconf $guiconf \
+ || die "gvim configure failed"
+ # Parallel make does not work
+ make || die "gvim make failed"
+ mv src/vim src/gvim
+ fi
+
+ #
+ # Second, build a nogui version, this will install as /usr/bin/vim
+ #
./configure \
- --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
- --enable-max-features --enable-cscope $myconf $guiconf \
- || die "gvim configure failed"
+ --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
+ --enable-max-features --with-cscope $myconf \
+ --enable-gui=no --without-x \
+ || die "vim configure failed"
# Parallel make does not work
- make || die "gvim make failed"
- mv src/vim src/gvim
- fi
-
- #
- # Second, build a nogui version, this will install as /usr/bin/vim
- #
- ./configure \
- --prefix=/usr --mandir=/usr/share/man --host=$CHOST \
- --enable-max-features --with-cscope $myconf \
- --enable-gui=no --without-x \
- || die "vim configure failed"
- # Parallel make does not work
- make || die "vim make failed"
+ make || die "vim make failed"
}
src_install() {
- # Install the nogui version
- mkdir -p $D/usr/{bin,share/man/man1,share/vim}
- make install STRIP=true DESTDIR=$D \
- BINDIR=/usr/bin MANDIR=/usr/share/man DATADIR=/usr/share
- # Install the gui version, if it was built
- if [ -f src/gvim ]; then
- install -m755 src/gvim $D/usr/bin/gvim
- ln -s gvim $D/usr/bin/gvimdiff
- fi
- # Docs
- dodoc README*
- cd $D/usr/share/doc/$PF
- ln -s ../../vim/*/doc $P
- # .vimrc for root
- mkdir -p $D/root
- install -m644 $FILESDIR/vimrc $D/root/.vimrc
- # Default .vimrc for users (this should be revisited)
- insinto /etc/skel
- newins $FILESDIR/vimrc .vimrc
+ # Install the nogui version
+ mkdir -p $D/usr/{bin,share/man/man1,share/vim}
+ make install STRIP=true DESTDIR=$D \
+ BINDIR=/usr/bin MANDIR=/usr/share/man DATADIR=/usr/share
+ # Install the gui version, if it was built
+ if [ -f src/gvim ]; then
+ install -m755 src/gvim $D/usr/bin/gvim
+ ln -s gvim $D/usr/bin/gvimdiff
+ fi
+ # Docs
+ dodoc README*
+ cd $D/usr/share/doc/$PF
+ ln -s ../../vim/*/doc $P
+ # .vimrc for root
+ mkdir -p $D/root
+ install -m644 $FILESDIR/vimrc $D/root/.vimrc
+ # Default .vimrc for users (this should be revisited)
+ insinto /etc/skel
+ newins $FILESDIR/vimrc .vimrc
}