summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2005-07-10 21:32:36 +0000
committerDaniel Drake <dsd@gentoo.org>2005-07-10 21:32:36 +0000
commit91ddb9c8b5a6cc0ff3be55d57d512090714c5c03 (patch)
treee5ec470fe4474186968bd31a189f867dd60bf076
parent#98534: ./configure can now find x11 in gentoo; patch thanks to basic <basic@... (diff)
downloadhistorical-91ddb9c8b5a6cc0ff3be55d57d512090714c5c03.tar.gz
historical-91ddb9c8b5a6cc0ff3be55d57d512090714c5c03.tar.bz2
historical-91ddb9c8b5a6cc0ff3be55d57d512090714c5c03.zip
Convert to linux-mod, closes bug #98563
Package-Manager: portage-1.589-cvs
-rw-r--r--sys-apps/rlocate/ChangeLog7
-rw-r--r--sys-apps/rlocate/Manifest12
-rw-r--r--sys-apps/rlocate/files/digest-rlocate-0.3.1-r11
-rw-r--r--sys-apps/rlocate/rlocate-0.3.1-r1.ebuild55
4 files changed, 69 insertions, 6 deletions
diff --git a/sys-apps/rlocate/ChangeLog b/sys-apps/rlocate/ChangeLog
index ddad75d38b58..67bca4472e40 100644
--- a/sys-apps/rlocate/ChangeLog
+++ b/sys-apps/rlocate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-apps/rlocate
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.2 2005/07/09 22:39:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/ChangeLog,v 1.3 2005/07/10 21:32:36 dsd Exp $
+
+*rlocate-0.3.1-r1 (10 Jul 2005)
+
+ 10 Jul 2005; Daniel Drake <dsd@gentoo.org> +rlocate-0.3.1-r1.ebuild:
+ Convert to linux-mod, closes bug #98563
*rlocate-0.3.1 (09 Jul 2005)
diff --git a/sys-apps/rlocate/Manifest b/sys-apps/rlocate/Manifest
index 99bb402d21ea..d1c39a7d7b40 100644
--- a/sys-apps/rlocate/Manifest
+++ b/sys-apps/rlocate/Manifest
@@ -1,16 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
+MD5 bdf37b226b9c579b537fc9e8675a431b rlocate-0.3.1-r1.ebuild 1383
MD5 54f252fa644750b0ff8b2f93e427b2be rlocate-0.3.1.ebuild 1087
-MD5 67c95e12f6253de917993e683db2cc1c ChangeLog 481
+MD5 dd5a5a269d18a4ea00f6c59e266ac2a6 ChangeLog 625
+MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 1ec3228b5629dfb2b893f3b05322a055 rlocate-0.3.0.ebuild 1087
MD5 3df7d026a132a54c32b590868c901eee files/digest-rlocate-0.3.0 65
MD5 de57aa1ae3c55df794f8a28eaea3a826 files/digest-rlocate-0.3.1 65
+MD5 de57aa1ae3c55df794f8a28eaea3a826 files/digest-rlocate-0.3.1-r1 65
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-iD8DBQFC0FJ3gIKl8Uu19MoRAoiiAJ9Vu2m16FHyTPjDNtIAYwM+aJ1TdwCfZEkt
-snDCxQ0ZmwEF/yLC8FpYfiM=
-=ljaQ
+iD8DBQFC0ZUtTOXg++0VvJQRAoXUAJ4ze+jR1HCeawPRdNHCmnnsKSSSQQCfXL1i
+H4KTY/nOOtV6mqTCP2CuvcU=
+=cwZp
-----END PGP SIGNATURE-----
diff --git a/sys-apps/rlocate/files/digest-rlocate-0.3.1-r1 b/sys-apps/rlocate/files/digest-rlocate-0.3.1-r1
new file mode 100644
index 000000000000..42f85205aff1
--- /dev/null
+++ b/sys-apps/rlocate/files/digest-rlocate-0.3.1-r1
@@ -0,0 +1 @@
+MD5 d65e350fe83480cc1db40912a0dfa87b rlocate-0.3.1.tar.gz 190793
diff --git a/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild b/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..d74450225bce
--- /dev/null
+++ b/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/rlocate/rlocate-0.3.1-r1.ebuild,v 1.1 2005/07/10 21:32:36 dsd Exp $
+
+inherit eutils linux-mod
+
+DESCRIPTION="locate implementation that is always up-to-date"
+HOMEPAGE="http://rlocate.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rlocate/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="!sys-apps/slocate"
+
+pkg_setup() {
+ MODULE_NAMES="rlocate(misc:${S}/rlocate-module)"
+ CONFIG_CHECK="SECURITY"
+ SECURITY_ERROR="You need to select the \"Enable different security models\" option in the kernel configuration (CONFIG_SECURITY)."
+ BUILD_TARGETS="all"
+ linux-mod_pkg_setup
+
+ enewgroup locate
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/^RLOCATE_GRP/s:=.*:=locate:' \
+ -e 's/rlocate-module//g' \
+ Makefile.in || die "sed group"
+ rm -f rlocate-scripts/Makefile
+ sed -i \
+ -e '/groupadd/d' \
+ -e '/chown/s/root:$(rlocate)/root:locate/g' \
+ Makefile.in rlocate-scripts/Makefile.in
+ sed -i \
+ -e '/DRLOCATE_GRP/s:$(rlocate):locate:' \
+ rlocate-daemon/Makefile.in
+}
+
+src_compile() {
+ econf --enable-sandboxed --with-kernel=${KV_DIR} || die
+ emake || die
+ linux-mod_src_compile
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ linux-mod_src_install
+ dodoc AUTHORS ChangeLog* NEWS README
+}