summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-09-19 07:39:39 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-09-19 07:39:39 +0000
commit852abb09d61d2d3770f0d0609b34ecffecbd020d (patch)
treeae582c3321c3b85fa834486e52078a680b8c0a81
parentFixed HOMEPAGE variable (diff)
downloadhistorical-852abb09d61d2d3770f0d0609b34ecffecbd020d.tar.gz
historical-852abb09d61d2d3770f0d0609b34ecffecbd020d.tar.bz2
historical-852abb09d61d2d3770f0d0609b34ecffecbd020d.zip
See the changelog.
-rw-r--r--sys-kernel/lolo-sources/ChangeLog31
-rw-r--r--sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre12
-rw-r--r--sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre1.ebuild114
3 files changed, 146 insertions, 1 deletions
diff --git a/sys-kernel/lolo-sources/ChangeLog b/sys-kernel/lolo-sources/ChangeLog
index a0738ebb6c08..be13657ac7d8 100644
--- a/sys-kernel/lolo-sources/ChangeLog
+++ b/sys-kernel/lolo-sources/ChangeLog
@@ -1,6 +1,35 @@
# ChangeLog for sys-kernel/lolo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.4 2002/09/03 02:14:33 lostlogic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/lolo-sources/ChangeLog,v 1.5 2002/09/19 07:39:39 lostlogic Exp $
+
+*lolo-sources-2.4.19.10_pre1 (19 Sep 2002)
+
+ 19 Sep 2002; Brandon Low <lostlogic@gentoo.org> lolo-sources-2.4.19.10_pre1.ebuild:
+
+ Fix kernel version to not confuse mozilla any more, this kernel's
+ designation is officially linux-2.4.19-r10-lolo_pre1, and no I don't
+ care if you hate my naming scheme... it clearly attaches my
+ pre-release kernels to their appropriate gentoo-sources releases, etc.
+
+ Updated all patches with known updates to their latest
+ (JFS, preempt, rmap, nfs, nfs-over-tcp)
+
+ Add xattr and acl patches and include the JFS patches for them.
+
+ Add supermount patches.
+
+ Incorportate the small fixes done to gentoo-sources-2.4.19-r9 into
+ the main patchball.
+
+ Coming before gentoo-sources-2.4.19-r10:
+ - updated grsecurity, pending upstream release
+ - updated defconfig patch with better defaults for i386
+ - updated and improved patches.txt documentation
+ - backports for AMD74xx, radeonfb, and HPT366 driverd from -ac
+ done by Michael Cohen <mjc@gentoo.org>
+ - incorporate ACPI from acpi.sourceforge.net
+ - Possibly other, depending on stability, timing, and how much I get
+ harrassed about things :)
*lolo-sources-2.4.19.9_rc2 (02 Sep 2002)
diff --git a/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre1 b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre1
new file mode 100644
index 000000000000..3599d5e85321
--- /dev/null
+++ b/sys-kernel/lolo-sources/files/digest-lolo-sources-2.4.19.10_pre1
@@ -0,0 +1,2 @@
+MD5 2bb60b7594a416f2c593923ce446160b linux-2.4.19.tar.bz2 26042494
+MD5 f98e27a7de1470b2a83fd6ab683a9b16 patches-2.4.19-r10-lolo_pre1.tar.bz2 1441946
diff --git a/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre1.ebuild b/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre1.ebuild
new file mode 100644
index 000000000000..f302fff80a19
--- /dev/null
+++ b/sys-kernel/lolo-sources/lolo-sources-2.4.19.10_pre1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+OKV="`echo ${PV}|sed -e 's:\(^.*\)\.[^\.]*:\1:'`"
+EXTRAVERSION="`echo ${PV}|sed -e 's:[0-9]\+\.[0-9]\+\.[0-9]\+\.\([0-9]*\)\(.*$\):-r\1-lolo\2:'`"
+KV=${OKV}${EXTRAVERSION}
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+#Documentation on the patches contained in this kernel will be installed
+#to /usr/share/doc/lolo-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for lostlogic's Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ http://gentoo.lostlogicx.com/patches-${KV}.tar.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+
+if [ $ETYPE = "sources" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND="!build? ( >=sys-devel/binutils-2.11.90.0.31 )"
+ RDEPEND="${RDEPEND}
+ !build? ( >=sys-libs/ncurses-5.2
+ sys-devel/perl
+ >=sys-apps/modutils-2.4.2
+ sys-devel/make )"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -Os -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ # Now we need to deal with the tarball of patches.
+ cd ${KV}
+ [ `use crypt` ] || rm 8*
+ #Thers is some anti-grsecurity sentiment, so I'll
+ #make it easy not to patch it in.
+ #Uncomment the following line to not patch grsecurity.
+ #rm 14*
+
+ ./addpatches . ${WORKDIR}/linux-${KV} || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ # also fix the EXTRAVERSION
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ -e "s:^\(EXTRAVERSION =\).*:\1 ${EXTRAVERSION}:" \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make distclean || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ cat ${WORKDIR}/${KV}/docs/* > patches.txt
+ dodoc patches.txt
+ mv ${WORKDIR}/linux* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}