summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-25 08:40:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-25 08:40:43 +0000
commit6fc5dff42670801224249b0aff66a6ee3db2b548 (patch)
treea1386d7c7fb7688409c7749bb8dd09ea064c7afb
parentNew version of the Gentoo grub patchset. Provides support for 256-byte ext3 i... (diff)
downloadhistorical-6fc5dff42670801224249b0aff66a6ee3db2b548.tar.gz
historical-6fc5dff42670801224249b0aff66a6ee3db2b548.tar.bz2
historical-6fc5dff42670801224249b0aff66a6ee3db2b548.zip
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>. This is useful for testing crazy GPT setups.
Package-Manager: portage-2.1.4.4
-rw-r--r--sys-boot/mbr-gpt/ChangeLog11
-rw-r--r--sys-boot/mbr-gpt/Manifest4
-rw-r--r--sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild52
-rw-r--r--sys-boot/mbr-gpt/metadata.xml8
4 files changed, 75 insertions, 0 deletions
diff --git a/sys-boot/mbr-gpt/ChangeLog b/sys-boot/mbr-gpt/ChangeLog
new file mode 100644
index 000000000000..a8aa1d5fbed0
--- /dev/null
+++ b/sys-boot/mbr-gpt/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-boot/mbr-gpt
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/mbr-gpt/ChangeLog,v 1.1 2008/03/25 08:40:43 robbat2 Exp $
+
+*mbr-gpt-0.0.1 (25 Mar 2008)
+
+ 25 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +mbr-gpt-0.0.1.ebuild:
+ Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>. This is
+ useful for testing crazy GPT setups.
+
diff --git a/sys-boot/mbr-gpt/Manifest b/sys-boot/mbr-gpt/Manifest
new file mode 100644
index 000000000000..b3131b8b2c36
--- /dev/null
+++ b/sys-boot/mbr-gpt/Manifest
@@ -0,0 +1,4 @@
+DIST mbr-gpt_0.0.1.tar.gz 15861 RMD160 1d61afc95e558951709b604e6695a0cfbbf9d5f7 SHA1 e9cd243b8f139169edaf18ea5562a198270a7746 SHA256 c66cc48c6034f1db72ddba187a52f590001a946f87478171b3d362b601b26bc2
+EBUILD mbr-gpt-0.0.1.ebuild 1504 RMD160 5fc8649c465a7bfe17263cb92ce8e7e43b57bc2a SHA1 91d48e66d9acbc0471b638dba78cd7bcd03c7adf SHA256 167290a3ade11a0f565b08322aef8f8de8dc6f6333718fb3ccff27832299f533
+MISC ChangeLog 444 RMD160 7a18a9c92829ef546d61829f046a08d51dc3b8d9 SHA1 06fbd64a25f899e1ca5a050ef04058d7b6fe059b SHA256 e56fd8d94dca6c319ccb2f04210e3f6061e2a2983d3a3475fe7b6677e0952ae8
+MISC metadata.xml 227 RMD160 e54f63c709ba122fa8d5931652deb3821a967981 SHA1 84c05df3fda91de26beaaf15ffdbf4ea15b3784b SHA256 eb6179099f91f31168c95bd4a018a01f37aa1eb8d9ba8d3ed039056bac71bcf8
diff --git a/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
new file mode 100644
index 000000000000..4f82a8beb6dd
--- /dev/null
+++ b/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/mbr-gpt/mbr-gpt-0.0.1.ebuild,v 1.1 2008/03/25 08:40:43 robbat2 Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="An MBR that can handle BIOS-based boot on GPT."
+MY_P="${PN}_${PV}"
+HOMEPAGE="http://aybabtu.com/mbr-gpt/"
+SRC_URI="http://aybabtu.com/mbr-gpt/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+# This should probably NEVER go to stable. It's crazy advanced dangerous magic.
+# It's also pure ASM, so not suitable for elsewhere anyway.
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+# It only depends on binutils/gcc/make, and doesn't link against libc even.
+DEPEND=""
+RDEPEND=""
+
+# It's a mostly an MBR block and it does use the executable stack.
+QA_WX_LOAD="usr/sbin/boot.elf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ emake clean
+
+ # Need to build it 32-bit for the MBR
+ # Btw, no CFLAGS are respected, it's ASM!
+ use amd64 && sed -i -e 's/-Wall/-Wall -m32/g' "${S}"/Makefile
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ # get_libdir is not correct here. We want this to go into a 32-bit library
+ # location.
+ insinto /usr/lib/mbr-gpt/
+ doins mbr
+ dosbin boot.elf
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ einfo "See the instructions on the homepage, and make sure you know what"
+ einfo "you are doing before touching this. The mbr file does into your"
+ einfo "MBR, or alternatively you can do a creative reboot utilizing the"
+ einfo "boot.elf binary."
+}
diff --git a/sys-boot/mbr-gpt/metadata.xml b/sys-boot/mbr-gpt/metadata.xml
new file mode 100644
index 000000000000..035bc6b0e2cd
--- /dev/null
+++ b/sys-boot/mbr-gpt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>