summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-27 10:59:24 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-27 10:59:24 +0000
commit67d78885e0119d49fac5fd72d94bf3c9c5775087 (patch)
tree6bd574d11f96866f2384974b4d8eba45d08857e1
parentx11-drivers/xf86-video-i810: bump to 2.2.1 (diff)
downloadhistorical-67d78885e0119d49fac5fd72d94bf3c9c5775087.tar.gz
historical-67d78885e0119d49fac5fd72d94bf3c9c5775087.tar.bz2
historical-67d78885e0119d49fac5fd72d94bf3c9c5775087.zip
fix old bug: uninstalling with mod_install takes filename, not full path
Package-Manager: portage-2.2_pre2
-rw-r--r--sys-auth/tfm-fingerprint/Manifest8
-rw-r--r--sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild9
2 files changed, 10 insertions, 7 deletions
diff --git a/sys-auth/tfm-fingerprint/Manifest b/sys-auth/tfm-fingerprint/Manifest
index 01f0c963e457..631b1924e294 100644
--- a/sys-auth/tfm-fingerprint/Manifest
+++ b/sys-auth/tfm-fingerprint/Manifest
@@ -3,13 +3,13 @@ Hash: SHA1
AUX tfmessbsp.cfg 90 RMD160 632199fb73d4749392a073247b2d103d408f6f8f SHA1 6eeeadfe8dd1408a098b615eac11f19c34787127 SHA256 fd35cbf9e4e8d7abccad58d63f89c6df7af1e88ca86acce88d8311bca08cd1de
DIST TFMESS_BSP_LIN_1.0.zip 922652 RMD160 73f85b03e95db818147203a3149356b3fc47ed4a SHA1 c73466b5c3b26415b300d5c5ffb76deaefadeb32 SHA256 9ca1dcb059e326d4c760c8f8ceb4df5970ab9897062487453a2ac5e9e7058368
-EBUILD tfm-fingerprint-1.0.ebuild 1040 RMD160 f860baddddf7b8aa72fcfcff43cfff8514105d49 SHA1 b77a32cedc8ffead82697e7a30e7d54069b40d39 SHA256 e2e2f71412c98eb69eba0ddefcb68f158a6e60e73cbf2688016d74f83d8d5066
+EBUILD tfm-fingerprint-1.0.ebuild 1102 RMD160 4832fa75f761057feeb2cf5052e20e59828f3b28 SHA1 c922274f659934c3883d7de6f707323d04726827 SHA256 d0022f2279af6d4b43096c35a3589babb784729c2f01e13f9e4029a4a9fdb492
MISC ChangeLog 908 RMD160 429566fe23aaf3f531fc4fd5753c3f75841246a7 SHA1 e5f2b420459b55ed6dd464b8e8d57a4ea01db9e3 SHA256 1f813395c4b0d7f81701ca66424c58b2da20a05065de5e70e5e300c2a45537fc
MISC metadata.xml 252 RMD160 34a164bfc96b8845a8308e85a214d633284b763b SHA1 c3aabeacb7af064df74acfddbfda2ae0497ff8a5 SHA256 445ab0e7fb8f15ad8dea05dabee14ecc25c6b81bfb9a6213ff3d9ea81f759154
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
-iD8DBQFHxT4Tj9hvisErhMIRAg2iAJwOC5FiPZRa/+i/5eAPj2a3zOH2vwCfet75
-iDgkmvGT9xmFIniFDPDCjDg=
-=B9k+
+iD8DBQFHxUKRj9hvisErhMIRAl0cAJ4oYxcQGo2+ixp5Uz7z73GCD6yEQgCfYSuR
+6e8bjdUINHlSAnTdF5i/rlQ=
+=w3yh
-----END PGP SIGNATURE-----
diff --git a/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild b/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
index fc49bd04c1d3..60b33579426b 100644
--- a/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
+++ b/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild,v 1.2 2008/02/27 10:40:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/tfm-fingerprint/tfm-fingerprint-1.0.ebuild,v 1.3 2008/02/27 10:59:24 vapier Exp $
inherit multilib
@@ -35,6 +35,9 @@ pkg_postinst() {
elog "Note: You have to be in the group usb to access the fingerprint device."
}
-pkg_prerm() {
- doit_with_ewarn mod_install -fu /usr/$(get_libdir)/libtfmessbsp.so
+pkg_postrm() {
+ # only do this if uninstalling
+ if ! has_version ${CATEGORY}/${PN} ; then
+ doit_with_ewarn mod_install -fu libtfmessbsp.so
+ fi
}