summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-06-10 13:22:05 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-06-10 13:22:05 +0000
commit5ae23639782ec3cbfa117578e639c5504f9bad4c (patch)
tree859c444b6b0ba52739ea7fc176e99fa4c59eb55d
parentAdded to ~ppc (diff)
downloadhistorical-5ae23639782ec3cbfa117578e639c5504f9bad4c.tar.gz
historical-5ae23639782ec3cbfa117578e639c5504f9bad4c.tar.bz2
historical-5ae23639782ec3cbfa117578e639c5504f9bad4c.zip
Revision bump; upstream uses a char (and assumes it's unsigned on top of it) where they should've used an int - bug 95628.
Package-Manager: portage-2.0.51.22-r1
-rw-r--r--app-misc/detox/ChangeLog9
-rw-r--r--app-misc/detox/Manifest10
-rw-r--r--app-misc/detox/detox-1.1.1-r1.ebuild37
-rw-r--r--app-misc/detox/files/detox-1.1.1-use-correct-type.diff12
-rw-r--r--app-misc/detox/files/digest-detox-1.1.1-r11
5 files changed, 68 insertions, 1 deletions
diff --git a/app-misc/detox/ChangeLog b/app-misc/detox/ChangeLog
index 8b592450b7b7..b48c690915e7 100644
--- a/app-misc/detox/ChangeLog
+++ b/app-misc/detox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/detox
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/ChangeLog,v 1.5 2005/05/03 10:27:53 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/ChangeLog,v 1.6 2005/06/10 13:22:05 ka0ttic Exp $
+
+*detox-1.1.1-r1 (10 Jun 2005)
+
+ 10 Jun 2005; Aaron Walker <ka0ttic@gentoo.org>
+ +files/detox-1.1.1-use-correct-type.diff, +detox-1.1.1-r1.ebuild:
+ Revision bump; upstream uses a char (and assumes it's unsigned on top of it)
+ where they should've used an int - bug 95628.
03 May 2005; Herbie Hopkins <herbs@gentoo.org> detox-1.1.1.ebuild:
Marked ~amd64 wrt bug #91274.
diff --git a/app-misc/detox/Manifest b/app-misc/detox/Manifest
index 1985496eba3c..bb0d0b55e3a3 100644
--- a/app-misc/detox/Manifest
+++ b/app-misc/detox/Manifest
@@ -1,3 +1,6 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
MD5 3c8fd5d06b35e45e2b0f61c35db418af detox-1.1.1-r1.ebuild 834
MD5 66d5ada00136251bcfcf1f85b6849670 detox-1.1.0.ebuild 863
MD5 b540bef138b11f4192573345545f95f8 detox-1.1.1.ebuild 779
@@ -9,3 +12,10 @@ MD5 1d0744431cb2efc1a65dd1e56b11d41c files/digest-detox-1.1.0 63
MD5 4a6e35941158ffa59490cb244dd4327d files/digest-detox-1.1.1 63
MD5 61eb83c84fbace15d61c315160ca0e5e files/detox-1.1.0-parallel_build.patch 564
MD5 b3e822dc72f5d0721e6c570f0bf3fff8 files/detox-1.1.1-use-correct-type.diff 475
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCqZQXEZCkKN40op4RAreTAJ9fLTEWqx3PLMi83rOXyuD9j20dxwCfaIzd
+zUkaJ1nBHi40OlYlgUuYyzc=
+=IlPQ
+-----END PGP SIGNATURE-----
diff --git a/app-misc/detox/detox-1.1.1-r1.ebuild b/app-misc/detox/detox-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..cd817158e35c
--- /dev/null
+++ b/app-misc/detox/detox-1.1.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/detox/detox-1.1.1-r1.ebuild,v 1.1 2005/06/10 13:22:05 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="detox safely removes spaces and strange characters from filenames"
+HOMEPAGE="http://detox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/popt
+ sys-devel/flex
+ sys-devel/bison"
+
+RDEPEND="dev-libs/popt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-use-correct-type.diff
+}
+
+src_compile() {
+ econf --with-popt || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc README CHANGES
+}
+
diff --git a/app-misc/detox/files/detox-1.1.1-use-correct-type.diff b/app-misc/detox/files/detox-1.1.1-use-correct-type.diff
new file mode 100644
index 000000000000..124be9b3cc2a
--- /dev/null
+++ b/app-misc/detox/files/detox-1.1.1-use-correct-type.diff
@@ -0,0 +1,12 @@
+diff --exclude='*~' --exclude='.*' -I '$Id:' -urN detox-1.1.1.orig/parse_options_popt.c detox-1.1.1/parse_options_popt.c
+--- detox-1.1.1.orig/parse_options_popt.c 2005-03-04 20:54:56.000000000 -0500
++++ detox-1.1.1/parse_options_popt.c 2005-06-10 08:55:13.000000000 -0400
+@@ -69,7 +69,7 @@
+
+ char *work;
+
+- char c; /* used for argument parsing */
++ int c; /* used for argument parsing */
+ poptContext optCon; /* context for parsing command-line options */
+
+ int i;
diff --git a/app-misc/detox/files/digest-detox-1.1.1-r1 b/app-misc/detox/files/digest-detox-1.1.1-r1
new file mode 100644
index 000000000000..11dc51571918
--- /dev/null
+++ b/app-misc/detox/files/digest-detox-1.1.1-r1
@@ -0,0 +1 @@
+MD5 1219f38e34e56186ff18b3c0aa12bb0d detox-1.1.1.tar.bz2 53871