summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-21 12:18:47 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-21 12:18:47 +0000
commit5750b4fcd2e9f02672cf65c7641051fd1705f511 (patch)
tree80cf2124a9950cb287432b4194b5309b1270480e
parentStable for amd64, wrt bug #409053 (diff)
downloadhistorical-5750b4fcd2e9f02672cf65c7641051fd1705f511.tar.gz
historical-5750b4fcd2e9f02672cf65c7641051fd1705f511.tar.bz2
historical-5750b4fcd2e9f02672cf65c7641051fd1705f511.zip
New addition, written by me
Package-Manager: portage-2.2.0_alpha93/cvs/Linux x86_64
-rw-r--r--sci-chemistry/tm-align/ChangeLog10
-rw-r--r--sci-chemistry/tm-align/Manifest15
-rw-r--r--sci-chemistry/tm-align/files/CMakeLists.txt6
-rw-r--r--sci-chemistry/tm-align/metadata.xml24
-rw-r--r--sci-chemistry/tm-align/tm-align-20120124.ebuild25
5 files changed, 80 insertions, 0 deletions
diff --git a/sci-chemistry/tm-align/ChangeLog b/sci-chemistry/tm-align/ChangeLog
new file mode 100644
index 000000000000..03bc93a72827
--- /dev/null
+++ b/sci-chemistry/tm-align/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/tm-align
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tm-align/ChangeLog,v 1.1 2012/03/21 12:18:47 jlec Exp $
+
+*tm-align-20120124 (21 Mar 2012)
+
+ 21 Mar 2012; Justin Lecher <jlec@gentoo.org> +tm-align-20120124.ebuild,
+ +files/CMakeLists.txt, +metadata.xml:
+ New addition, written by me
+
diff --git a/sci-chemistry/tm-align/Manifest b/sci-chemistry/tm-align/Manifest
new file mode 100644
index 000000000000..a3b2e30b02f0
--- /dev/null
+++ b/sci-chemistry/tm-align/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA512
+
+AUX CMakeLists.txt 182 RMD160 d9164785928647ad17dea89bf145ca7730defb70 SHA1 a16d9187bfe94f33015e1f38afb4c75a3e8168f8 SHA256 e6543e2fba46dc09d1892106b1d9c154485ee269d2b88c16a1973605fae44b53
+DIST TMtools20120124.tar.gz 919534 RMD160 38b2625622c3ef6a46ddfadf645b52ffe5d2d1f8 SHA1 26e511e6f9ab25e2da80b6e2043acfbff23170b7 SHA256 0464557cdcbfb5559b96859f851f938ef63ada8bf990b9a2c4e49ec3659cc7c4
+EBUILD tm-align-20120124.ebuild 790 RMD160 a00430eab2fd4b8836a8767d44181c814167d577 SHA1 605662d75a86c47eb7f9667f492e0d7b7da4bf2f SHA256 b8c4e614c1496d6bab1811b7b68c48e36d406cd0968731cd73653ca90ec2b77c
+MISC ChangeLog 394 RMD160 71975034c9587dce89acffec0118090d2bc94baa SHA1 032622b53b747b13730d0b1c3578eb4d51554aff SHA256 16de9698124590b525024cd31fc5ec998808e8afbf5f75a9aa578107aefe8dd0
+MISC metadata.xml 1251 RMD160 0344c0c7cf2ffbc28a0de7288f374a3b0507346a SHA1 dcd08feba62d973bb8a26e82c853d2484bd7ddb6 SHA256 754c93dd5e927a037f96904578d06a9b0c694f9aa065980667c32a8b5398fac5
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.18 (GNU/Linux)
+
+iEYEAREKAAYFAk9pxywACgkQgAnW8HDreRYOCwCfWAjGyK41BuY0y4qLKPoKtPHt
+K3IAnjguHYQ6Vbkttq+2AJRETrykXk9y
+=ljqv
+-----END PGP SIGNATURE-----
diff --git a/sci-chemistry/tm-align/files/CMakeLists.txt b/sci-chemistry/tm-align/files/CMakeLists.txt
new file mode 100644
index 000000000000..506ef136309e
--- /dev/null
+++ b/sci-chemistry/tm-align/files/CMakeLists.txt
@@ -0,0 +1,6 @@
+cmake_minimum_required (VERSION 2.6)
+project (TMTools Fortran)
+add_executable(TMalign TMalign.f)
+add_executable(TMscore TMscore.f)
+
+install (TARGETS TMalign TMscore DESTINATION bin)
diff --git a/sci-chemistry/tm-align/metadata.xml b/sci-chemistry/tm-align/metadata.xml
new file mode 100644
index 000000000000..da6700a6429b
--- /dev/null
+++ b/sci-chemistry/tm-align/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+TM-align is a computer algorithm for protein structure alignment using dynamic
+programming and TM-score rotation matrix. An optimal alignment between two
+proteins, as well as the TM-score, will be reported for each comparison. The
+value of TM-score lies in (0,1]. In general, a comparison of TM-score smaller
+0.2 indicates that there is no similarity between two structures; a TM-score
+greater 0.5 means the structures share the same fold.
+
+What is the difference between TM-score and TM-align? The TM-score program
+is to compare two models based on their given and known residue equivalency.
+It is usually NOT applied to compare two proteins of different sequences. The
+TM-align is a structural alignment program for comparing two proteins whose
+sequences can be different. The TM-align will first find the best equivalent
+residues of two proteins based on the structure similarity and then output a
+TM-score. The TM-score values in both programs have the same definition.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/tm-align/tm-align-20120124.ebuild b/sci-chemistry/tm-align/tm-align-20120124.ebuild
new file mode 100644
index 000000000000..a6f7c565e0bd
--- /dev/null
+++ b/sci-chemistry/tm-align/tm-align-20120124.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/tm-align/tm-align-20120124.ebuild,v 1.1 2012/03/21 12:18:47 jlec Exp $
+
+EAPI=4
+
+inherit cmake-utils fortran-2
+
+DESCRIPTION="Quick & Accurate Structural Alignment"
+HOMEPAGE="http://zhanglab.ccmb.med.umich.edu/TM-align/"
+SRC_URI="http://zhanglab.ccmb.med.umich.edu/TM-align/TMtools${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static custom-cflags"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}"/CMakeLists.txt . || die
+ use static && append-fflags -static && append-ldflags -static
+ # recommended by upstream
+ use custom-cflags || replace-flags -O* -O3 && append-fflags -ffast-math
+}