summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-21 22:23:40 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-21 22:23:40 +0000
commit56168ffe0e156c0a413e1f2d58ab292990c0d6d5 (patch)
tree42d744dad17e3df25dd8a7b4bf500f1a385282bb
parentVersion bump. (diff)
downloadhistorical-56168ffe0e156c0a413e1f2d58ab292990c0d6d5.tar.gz
historical-56168ffe0e156c0a413e1f2d58ab292990c0d6d5.tar.bz2
historical-56168ffe0e156c0a413e1f2d58ab292990c0d6d5.zip
old
-rw-r--r--dev-libs/mpfr/mpfr-2.3.1_p1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-libs/mpfr/mpfr-2.3.1_p1.ebuild b/dev-libs/mpfr/mpfr-2.3.1_p1.ebuild
deleted file mode 100644
index de55736ceeed..000000000000
--- a/dev-libs/mpfr/mpfr-2.3.1_p1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mpfr/mpfr-2.3.1_p1.ebuild,v 1.7 2008/09/29 01:39:06 vapier Exp $
-
-# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
-inherit eutils
-
-MY_PV=${PV/_p*}
-MY_P=${PN}-${MY_PV}
-PLEVEL=${PV/*p}
-DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
-HOMEPAGE="http://www.mpfr.org/"
-SRC_URI="http://www.mpfr.org/mpfr-current/${MY_P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=dev-libs/gmp-4.1.4-r2"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack "${MY_P}.tar.bz2"
- cd "${S}"
- [[ ${PLEVEL} == ${PV} ]] && return 0
- for ((i=1; i<=PLEVEL; ++i)) ; do
- patch=patch$(printf '%02d' ${i})
- if [[ -f ${FILESDIR}/${MY_PV}/${patch} ]] ; then
- epatch "${FILESDIR}"/${MY_PV}/${patch}
- elif [[ -f ${DISTDIR}/${PN}-${MY_PV}_p${i} ]] ; then
- epatch "${DISTDIR}"/${PN}-${MY_PV}_p${i}
- else
- ewarn "${DISTDIR}/${PN}-${MY_PV}_p${i}"
- die "patch ${i} missing - please report to bugs.gentoo.org"
- fi
- done
- find -type f -print0 | xargs -0 touch -r configure
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dodoc AUTHORS BUGS ChangeLog NEWS README TODO
- dohtml *.html
-}