summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-07-25 15:39:55 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-07-25 15:39:55 +0000
commit3703a2b1aa7e6b06265144e431305245129e99f5 (patch)
tree7a2bda46bac0705d5c7d4eb575f7ef489525c07e
parentAdded missing keywords (diff)
downloadhistorical-3703a2b1aa7e6b06265144e431305245129e99f5.tar.gz
historical-3703a2b1aa7e6b06265144e431305245129e99f5.tar.bz2
historical-3703a2b1aa7e6b06265144e431305245129e99f5.zip
just removed some unneeded stuff, added a \|\| die, and fixed the disable of other version of gtk switches that i did not want to do in -r3 ... btw cardoe, i wont kill you, ill just know where to direct all mozilla-1.1beta bugs :P
-rw-r--r--net-www/mozilla/ChangeLog9
-rw-r--r--net-www/mozilla/mozilla-1.1_beta.ebuild15
2 files changed, 8 insertions, 16 deletions
diff --git a/net-www/mozilla/ChangeLog b/net-www/mozilla/ChangeLog
index 016f17aaa170..06721ba1f164 100644
--- a/net-www/mozilla/ChangeLog
+++ b/net-www/mozilla/ChangeLog
@@ -1,14 +1,13 @@
# ChangeLog for net-www/mozilla
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.28 2002/07/25 00:35:01 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/ChangeLog,v 1.29 2002/07/25 15:39:55 azarah Exp $
*mozilla-1.0-r4 (25 Jul 2002)
25 Jul 2002; Spider <spider@gentoo.org> mozilla-1.0-r4.ebuild:
minor changes to the build process, uses experimental makeedit.eclass
- this version shouldn't be unmasked except for testing, as it doesn't do anything constructive except make the build a bit leaner and smaller in RAM requirements.
-
-
-
+ this version shouldn't be unmasked except for testing, as it doesn't do
+ anything constructive except make the build a bit leaner and smaller in
+ RAM requirements.
13 Jul 2002; Martin Schlemmer <azarah@gentoo.org> mozilla.sh :
Update to fix a bug with gtk2 (mozilla-xremote-client are not created).
diff --git a/net-www/mozilla/mozilla-1.1_beta.ebuild b/net-www/mozilla/mozilla-1.1_beta.ebuild
index 28eb29afb708..233be7d291c8 100644
--- a/net-www/mozilla/mozilla-1.1_beta.ebuild
+++ b/net-www/mozilla/mozilla-1.1_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.1 2002/07/25 10:36:51 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/mozilla/mozilla-1.1_beta.ebuild,v 1.2 2002/07/25 15:39:55 azarah Exp $
# NOTE: to build without the mail and news component: export NO_MAIL="YES"
inherit makeedit
@@ -47,13 +47,6 @@ export BUILD_OFFICIAL=1
[ "${DISABLE_XFT}" != "1" ] && [ -z "`use gtk2`" ] && \
export MOZ_ENABLE_XFT=1
-# enable GTK+-2.0 support
-if [ "`use gtk2`" ] ; then
- export MOZ_ENABLE_GTK2=1
- export MOZ_WIDGET_GTK2=1
- export MOZ_WIDGET_TOOLKIT=gtk2
-fi
-
# make sure the nss module gets build (for NSS support)
[ -n "`use ssl`" ] && export MOZ_PSM=1
@@ -84,7 +77,7 @@ src_unpack() {
# http://bugzilla.mozilla.org/show_bug.cgi?id=116444
#
if [ "${ARCH}" = "x86" ] ; then
- patch -p0 < ${FILESDIR}/mozilla-1.0-abi-compat-wrappers.patch
+ patch -p0 < ${FILESDIR}/mozilla-1.0-abi-compat-wrappers.patch || die
fi
fi
@@ -113,13 +106,13 @@ src_compile() {
--enable-default-toolkit=gtk2 \
--disable-toolkit-qt \
--disable-toolkit-xlib \
- --disable-gtk"
+ --disable-toolkit-gtk"
else
myconf="${myconf} --enable-toolkit-gtk \
--enable-default-toolkit=gtk \
--disable-toolkit-qt \
--disable-toolkit-xlib \
- --disable-gtk2"
+ --disable-toolkit-gtk2"
fi
if [ -z "`use ldap`" ] ; then