summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-03 10:49:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-03 10:49:43 +0000
commit24572fc2d335c1f4048c6db2908a54f564e8ec5a (patch)
tree88e3012a3996bad95561a81d80cb4db39ba458b2
parentQuoting (diff)
downloadhistorical-24572fc2d335c1f4048c6db2908a54f564e8ec5a.tar.gz
historical-24572fc2d335c1f4048c6db2908a54f564e8ec5a.tar.bz2
historical-24572fc2d335c1f4048c6db2908a54f564e8ec5a.zip
Invalid header. Define RDEPEND.
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
-rw-r--r--x11-wm/matchbox-common/matchbox-common-0.9.1-r1.ebuild37
-rw-r--r--x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild18
-rw-r--r--x11-wm/matchbox-common/matchbox-common-0.9.1.ebuild38
3 files changed, 8 insertions, 85 deletions
diff --git a/x11-wm/matchbox-common/matchbox-common-0.9.1-r1.ebuild b/x11-wm/matchbox-common/matchbox-common-0.9.1-r1.ebuild
deleted file mode 100644
index bd675e831a17..000000000000
--- a/x11-wm/matchbox-common/matchbox-common-0.9.1-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 2006-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-common/matchbox-common-0.9.1-r1.ebuild,v 1.9 2009/03/14 03:52:15 solar Exp $
-
-inherit eutils versionator
-
-DESCRIPTION="Common files used by matchbox-panel and matchbox-desktop packages"
-HOMEPAGE="http://matchbox-project.org/"
-SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=x11-libs/libmatchbox-1.1"
-
-src_compile() {
- econf --disable-pda-folders \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
-
- # Insert our Xsession
- echo -e "#!/bin/sh\n\nmatchbox-session" > "${T}"/matchbox
- exeinto /etc/X11/Sessions
- doexe "${T}"/matchbox
-
- # Insert GDM/KDM xsession file
- wm=matchbox make_session_desktop MatchBox matchbox-session
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README
-}
diff --git a/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild b/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild
index 7873c71ed76c..273a49fb9022 100644
--- a/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild
+++ b/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild
@@ -1,30 +1,28 @@
-# Copyright 2006-2009 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild,v 1.3 2009/03/14 03:52:15 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-common/matchbox-common-0.9.1-r2.ebuild,v 1.4 2009/08/03 10:49:43 ssuominen Exp $
inherit eutils versionator
DESCRIPTION="Common files used by matchbox-panel and matchbox-desktop packages"
HOMEPAGE="http://matchbox-project.org/"
SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
IUSE="pda"
-DEPEND=">=x11-libs/libmatchbox-1.1"
+RDEPEND=">=x11-libs/libmatchbox-1.1"
+DEPEND="${RDEPEND}"
src_compile() {
-
- econf $(use_enable pda pda-folders) \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
+ econf $(use_enable pda pda-folders)
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
# Insert our Xsession
echo -e "#!/bin/sh\n\nmatchbox-session" > "${T}"/matchbox
diff --git a/x11-wm/matchbox-common/matchbox-common-0.9.1.ebuild b/x11-wm/matchbox-common/matchbox-common-0.9.1.ebuild
deleted file mode 100644
index 0f4a73d23906..000000000000
--- a/x11-wm/matchbox-common/matchbox-common-0.9.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 2006-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-common/matchbox-common-0.9.1.ebuild,v 1.6 2009/03/14 03:52:15 solar Exp $
-
-inherit versionator
-
-DESCRIPTION="Common files used by matchbox-panel and matchbox-desktop packages"
-HOMEPAGE="http://matchbox-project.org/"
-SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=x11-libs/libmatchbox-1.1"
-
-src_compile() {
- econf --disable-pda-folders \
- || die "Configuration failed"
-
- emake || die "Compilation failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "Installation failed"
-
- # Insert our Xsession
- dodir /etc/X11/Sessions
- echo "matchbox-session" > "${D}"/etc/X11/Sessions/matchbox
- exeinto /etc/X11/Sessions
- doexe /etc/X11/Sessions/matchbox
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}"/MatchBox.desktop
-
- dodoc AUTHORS ChangeLog INSTALL NEWS README
-}