summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-19 19:03:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-19 19:03:27 +0000
commit1bd2065de193d7c4faf3538460a54127da66493c (patch)
tree131d04bbe48ccf2b9b83dad46717bfaf5caf4f05
parentDelete older ebuild. (diff)
downloadhistorical-1bd2065de193d7c4faf3538460a54127da66493c.tar.gz
historical-1bd2065de193d7c4faf3538460a54127da66493c.tar.bz2
historical-1bd2065de193d7c4faf3538460a54127da66493c.zip
Restrict Jython ABIs.
Package-Manager: portage-2.2.0_alpha9_p4/cvs/Linux x86_64
-rw-r--r--dev-python/PyQt4/ChangeLog6
-rw-r--r--dev-python/PyQt4/PyQt4-4.7.3.ebuild3
-rw-r--r--dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild3
-rw-r--r--dev-python/PyQt4/PyQt4-4.8.1.ebuild3
-rw-r--r--dev-python/qscintilla-python/ChangeLog6
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild3
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild3
-rw-r--r--dev-python/sip/ChangeLog6
-rw-r--r--dev-python/sip/sip-4.10.2.ebuild3
-rw-r--r--dev-python/sip/sip-4.11.2.ebuild3
10 files changed, 29 insertions, 10 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 94d8f592a80f..adb93270781a 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.136 2010/12/19 18:51:55 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.137 2010/12/19 18:54:31 arfrever Exp $
+
+ 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ PyQt4-4.7.3.ebuild, PyQt4-4.7.7-r1.ebuild, PyQt4-4.8.1.ebuild:
+ Restrict Jython ABIs.
19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-files/PyQt4-4.5.4-qgraphicslinearlayout-fix.patch,
diff --git a/dev-python/PyQt4/PyQt4-4.7.3.ebuild b/dev-python/PyQt4/PyQt4-4.7.3.ebuild
index 86879034d276..a9e0ffffea48 100644
--- a/dev-python/PyQt4/PyQt4-4.7.3.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.7.3.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.7.3.ebuild,v 1.11 2010/11/06 17:32:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.7.3.ebuild,v 1.12 2010/12/19 18:54:31 arfrever Exp $
EAPI="2"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit qt4-r2 python toolchain-funcs
diff --git a/dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild b/dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild
index 1729f7e54bec..276b778910fe 100644
--- a/dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild,v 1.2 2010/11/06 17:32:34 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.7.7-r1.ebuild,v 1.3 2010/12/19 18:54:31 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit qt4-r2 python toolchain-funcs
diff --git a/dev-python/PyQt4/PyQt4-4.8.1.ebuild b/dev-python/PyQt4/PyQt4-4.8.1.ebuild
index 733ccab2cac2..dfa0dab4a28e 100644
--- a/dev-python/PyQt4/PyQt4-4.8.1.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.8.1.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.8.1.ebuild,v 1.3 2010/11/07 14:17:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.8.1.ebuild,v 1.4 2010/12/19 18:54:31 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit python qt4-r2 toolchain-funcs
diff --git a/dev-python/qscintilla-python/ChangeLog b/dev-python/qscintilla-python/ChangeLog
index b237998946bd..d38c5acf8489 100644
--- a/dev-python/qscintilla-python/ChangeLog
+++ b/dev-python/qscintilla-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/qscintilla-python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.66 2010/12/19 19:01:03 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/ChangeLog,v 1.67 2010/12/19 19:03:27 arfrever Exp $
+
+ 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ qscintilla-python-2.4.3.ebuild, qscintilla-python-2.4.5.ebuild:
+ Restrict Jython ABIs.
19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-qscintilla-python-2.4.ebuild:
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild
index cdc8ba8e4593..b702754a1043 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild,v 1.9 2010/11/06 17:37:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.3.ebuild,v 1.10 2010/12/19 19:03:27 arfrever Exp $
EAPI="2"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit eutils python toolchain-funcs
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild
index 1a1b1399cc79..abc1f221dc08 100644
--- a/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild
+++ b/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild,v 1.2 2010/11/06 17:37:35 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/qscintilla-python/qscintilla-python-2.4.5.ebuild,v 1.3 2010/12/19 19:03:27 arfrever Exp $
EAPI="2"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit eutils python toolchain-funcs
diff --git a/dev-python/sip/ChangeLog b/dev-python/sip/ChangeLog
index a48a3fb0a66f..7989722ce506 100644
--- a/dev-python/sip/ChangeLog
+++ b/dev-python/sip/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sip
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.178 2010/12/19 18:57:11 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/ChangeLog,v 1.179 2010/12/19 18:59:17 arfrever Exp $
+
+ 19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ sip-4.10.2.ebuild, sip-4.11.2.ebuild:
+ Restrict Jython ABIs.
19 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-sip-4.8.2.ebuild, -sip-4.9.3-r1.ebuild, -sip-4.11.1.ebuild:
diff --git a/dev-python/sip/sip-4.10.2.ebuild b/dev-python/sip/sip-4.10.2.ebuild
index 018ef51df7f0..0c1f405c995e 100644
--- a/dev-python/sip/sip-4.10.2.ebuild
+++ b/dev-python/sip/sip-4.10.2.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.2.ebuild,v 1.9 2010/10/23 17:19:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.10.2.ebuild,v 1.10 2010/12/19 18:59:17 arfrever Exp $
EAPI="2"
PYTHON_DEPEND="*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit eutils python toolchain-funcs
diff --git a/dev-python/sip/sip-4.11.2.ebuild b/dev-python/sip/sip-4.11.2.ebuild
index 560115d150db..6bd24753c8b1 100644
--- a/dev-python/sip/sip-4.11.2.ebuild
+++ b/dev-python/sip/sip-4.11.2.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.11.2.ebuild,v 1.1 2010/10/23 11:23:57 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.11.2.ebuild,v 1.2 2010/12/19 18:59:17 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython"
inherit eutils python toolchain-funcs