summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-01-14 17:51:14 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-01-14 17:51:14 +0000
commit1ba129535c830df0d1be59ec03d9212b2cbb1bcc (patch)
treee98fb0d3820c42a2ec48072895e88243b2c01e6a
parentremoved superfluous code in ebuild.sh and fixed a maintainer flag (diff)
downloadhistorical-1ba129535c830df0d1be59ec03d9212b2cbb1bcc.tar.gz
historical-1ba129535c830df0d1be59ec03d9212b2cbb1bcc.tar.bz2
historical-1ba129535c830df0d1be59ec03d9212b2cbb1bcc.zip
added installation of compatibility headers to /usr/include/gdbm,
cleaned up the ebuild also
-rw-r--r--sys-libs/gdbm/files/digest-gdbm-1.8.0-r41
-rw-r--r--sys-libs/gdbm/gdbm-1.8.0-r4.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sys-libs/gdbm/files/digest-gdbm-1.8.0-r4 b/sys-libs/gdbm/files/digest-gdbm-1.8.0-r4
new file mode 100644
index 000000000000..d7e8e257c06a
--- /dev/null
+++ b/sys-libs/gdbm/files/digest-gdbm-1.8.0-r4
@@ -0,0 +1 @@
+MD5 cd543862287f55ad66e62cc9d82cc906 gdbm-1.8.0.tar.gz 135168
diff --git a/sys-libs/gdbm/gdbm-1.8.0-r4.ebuild b/sys-libs/gdbm/gdbm-1.8.0-r4.ebuild
new file mode 100644
index 000000000000..5b453868b92c
--- /dev/null
+++ b/sys-libs/gdbm/gdbm-1.8.0-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# Chad Huneycutt <chad.huneycutt@acm.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gdbm/gdbm-1.8.0-r4.ebuild,v 1.1 2002/01/14 17:51:14 gbevin Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard GNU database libraries included for compatibility with Perl"
+SRC_URI="ftp://prep.ai.mit.edu/gnu/gdbm/${P}.tar.gz"
+
+HOMEPAGE="http://www.gnu.org/software/gdbm/gdbm.html"
+
+DEPEND="virtual/glibc
+ berkdb? ( =sys-libs/db-1.85-r1 )"
+
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${WORKDIR}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+
+}
+
+src_compile() {
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+ emake CFLAGS="${CFLAGS} -fomit-frame-pointer" ${MAKEOPTS} || die
+
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ man3dir=${D}/usr/share/man/man3 \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ make includedir=${D}/usr/include/gdbm \
+ install-compat || die
+
+ dodoc COPYING ChangeLog NEWS README
+
+}