summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-11-01 00:23:08 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-11-01 00:23:08 +0000
commit0bd9e6d48139eb746783d3592de1df75a4ce07fb (patch)
tree6be6c6b6837d1ff13085ff567e8bb4fc537c7053
parentVersion bump. (diff)
downloadhistorical-0bd9e6d48139eb746783d3592de1df75a4ce07fb.tar.gz
historical-0bd9e6d48139eb746783d3592de1df75a4ce07fb.tar.bz2
historical-0bd9e6d48139eb746783d3592de1df75a4ce07fb.zip
Revision bump, need corrected makefile to disable AAC. Forcibly disable AAC, closes bug #110987.
Package-Manager: portage-2.0.53_rc7
-rw-r--r--media-sound/audacious/ChangeLog9
-rw-r--r--media-sound/audacious/Manifest13
-rw-r--r--media-sound/audacious/audacious-0.1-r1.ebuild97
-rw-r--r--media-sound/audacious/files/0.1-aac-makefile.am3
-rw-r--r--media-sound/audacious/files/digest-audacious-0.1-r12
5 files changed, 118 insertions, 6 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 566462061ee4..51b826f59a56 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.3 2005/10/30 21:56:57 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.4 2005/11/01 00:23:08 chainsaw Exp $
+
+*audacious-0.1-r1 (01 Nov 2005)
+
+ 01 Nov 2005; <chainsaw@gentoo.org> +files/0.1-aac-makefile.am,
+ +audacious-0.1-r1.ebuild:
+ Revision bump, need corrected makefile to disable AAC. Forcibly disable AAC,
+ closes bug #110987.
30 Oct 2005; Petteri Räty <betelgeuse@gentoo.org> audacious-0.1.ebuild:
Added ~x86 keyword requested in bug #110892.
diff --git a/media-sound/audacious/Manifest b/media-sound/audacious/Manifest
index b4c40481d8ed..745b220e1151 100644
--- a/media-sound/audacious/Manifest
+++ b/media-sound/audacious/Manifest
@@ -1,14 +1,17 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 27867d148cf6fbfd0fc51c79573f7db9 ChangeLog 841
+MD5 38b92aa5cab608ad73d6cf911a68c74e ChangeLog 1067
+MD5 c3376d424173ce085c75a4844b6c9a47 audacious-0.1-r1.ebuild 2382
MD5 4e61d378d0609e70a10b2e34c9fe5d68 audacious-0.1.ebuild 2399
+MD5 91d8a8b27023cfe143010b46f5d97ffb files/0.1-aac-makefile.am 52
MD5 556a78b44b63b6950de07d76f6261e8f files/digest-audacious-0.1 134
+MD5 556a78b44b63b6950de07d76f6261e8f files/digest-audacious-0.1-r1 134
MD5 319fe8f45b51a2d31f8d4e9a4071ca10 metadata.xml 248
-----BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
+Version: GnuPG v1.4.2-ecc0.1.6 (GNU/Linux)
-iD8DBQFDZUHAQiJ/wx066S4RApYqAJ9DCWH4ftN4Krg21MhK0EqyP79JtQCfegP7
-qndd9lZN+QNQ7a+74Py+h0Y=
-=VdHQ
+iD8DBQFDZrV+p5vW4rUFj5oRAm/yAKCJaK7dykBUl9DIP9yyJbTcFnerMQCcCngS
+J+joe1ALa3bJVzvd6jPZ2Z8=
+=OB3s
-----END PGP SIGNATURE-----
diff --git a/media-sound/audacious/audacious-0.1-r1.ebuild b/media-sound/audacious/audacious-0.1-r1.ebuild
new file mode 100644
index 000000000000..fbd7c41c40a7
--- /dev/null
+++ b/media-sound/audacious/audacious-0.1-r1.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-0.1-r1.ebuild,v 1.1 2005/11/01 00:23:08 chainsaw Exp $
+
+IUSE="alsa esd flac gnome mmx mp3 nls oss sdl vorbis"
+
+inherit flag-o-matic eutils libtool autotools
+
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions."
+HOMEPAGE="http://audacious.nenolod.net/Main_Page"
+SRC_URI="http://audacious.nenolod.net/release/audacious-0.1.tgz
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-arch/unzip
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/libglade-2.3.1
+ alsa? ( >=media-libs/alsa-lib-1.0.9_rc2 )
+ esd? ( >=media-sound/esound-0.2.30 )
+ flac? ( >=media-libs/libvorbis-1.0
+ >=media-libs/flac-1.1.2 )
+ gnome? ( >=gnome-base/gconf-2.6.0 )
+ mp3? ( media-libs/id3lib )
+ sdl? ( >=media-libs/libsdl-1.2.5 )
+ vorbis? ( >=media-libs/libvorbis-1.0
+ >=media-libs/libogg-1.0 )"
+
+DEPEND="${RDEPEND}
+ nls? ( dev-util/intltool )
+ >=dev-util/pkgconfig-0.9.0"
+
+src_unpack() {
+ if ! useq mp3; then
+ ewarn "MP3 support is now optional and you have not enabled it."
+ fi
+
+ unpack ${A}
+ cd ${S}
+
+ cp ${FILESDIR}/${PV}-aac-makefile.am ${S}/Plugins/Input/aac/Makefile.am
+
+ eautoreconf
+ elibtoolize
+}
+
+src_compile() {
+ # Bug #42893
+ replace-flags "-Os" "-O2"
+ # Bug #86689
+ is-flag "-O*" || append-flags -O
+
+ econf \
+ --disable-aac \
+ --disable-mikmod \
+ --with-dev-dsp=/dev/sound/dsp \
+ --with-dev-mixer=/dev/sound/mixer \
+ --includedir=/usr/include/audacious \
+ `use_enable mmx simd` \
+ `use_enable gnome gconf` \
+ `use_enable vorbis` \
+ `use_enable esd` \
+ `use_enable mp3` \
+ `use_enable nls` \
+ `use_enable oss` \
+ `use_enable alsa` \
+ `use_enable flac` \
+ || die
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ NEWS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins ${WORKDIR}/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc ${WORKDIR}/README
+
+ # XMMS skin symlinking; bug 70697
+ for SKIN in /usr/share/xmms/Skins/* ; do
+ dosym "$SKIN" /usr/share/audacious/Skins/
+ done
+}
+
+pkg_postinst() {
+ echo
+ einfo "Your XMMS skins, if any, have been symlinked."
+ einfo "MP3 support is now optional, you may want to enable the mp3 USE-flag."
+ echo
+}
diff --git a/media-sound/audacious/files/0.1-aac-makefile.am b/media-sound/audacious/files/0.1-aac-makefile.am
new file mode 100644
index 000000000000..67cbd08d8913
--- /dev/null
+++ b/media-sound/audacious/files/0.1-aac-makefile.am
@@ -0,0 +1,3 @@
+if ENABLE_AAC
+SUBDIRS = libmp4v2 libfaad2 src
+endif
diff --git a/media-sound/audacious/files/digest-audacious-0.1-r1 b/media-sound/audacious/files/digest-audacious-0.1-r1
new file mode 100644
index 000000000000..330adcc335bb
--- /dev/null
+++ b/media-sound/audacious/files/digest-audacious-0.1-r1
@@ -0,0 +1,2 @@
+MD5 540865e944f41a5bb082b13c6b8fd686 audacious-0.1.tgz 2385825
+MD5 41eababfa8bad11e9e34e467cdfb86be gentoo_ice-xmms-0.2.tar.bz2 51839