summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/pshs/pshs-9999.ebuild')
-rw-r--r--www-servers/pshs/pshs-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/www-servers/pshs/pshs-9999.ebuild b/www-servers/pshs/pshs-9999.ebuild
index 892184e3cdbc..6d71ea0c59aa 100644
--- a/www-servers/pshs/pshs-9999.ebuild
+++ b/www-servers/pshs/pshs-9999.ebuild
@@ -5,15 +5,12 @@
EAPI=5
#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://bitbucket.org/mgorny/${PN}.git"
-inherit git-r3
+inherit autotools git-r3
#endif
-inherit autotools-utils
-
-DESCRIPTION="Pretty small HTTP server - a command-line tool to share files"
+DESCRIPTION="Pretty small HTTP server -- a command-line tool to share files"
HOMEPAGE="https://bitbucket.org/mgorny/pshs/"
SRC_URI="https://www.bitbucket.org/mgorny/${PN}/downloads/${P}.tar.bz2"
@@ -36,10 +33,12 @@ DEPEND="${RDEPEND}
#if LIVE
KEYWORDS=
SRC_URI=
+
+src_prepare() { eautoreconf; }
#endif
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_enable magic libmagic)
$(use_enable netlink)
$(use_enable qrcode qrencode)
@@ -47,5 +46,5 @@ src_configure() {
$(use_enable upnp)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
}