summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-process/memwatch/memwatch-0.3.0-r1.ebuild')
-rw-r--r--sys-process/memwatch/memwatch-0.3.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.0-r1.ebuild b/sys-process/memwatch/memwatch-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..804b28eaef3d
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.3.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://unixdev.ru/memwatch"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST="FindCurses"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}