summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libvpd')
-rw-r--r--sys-libs/libvpd/Manifest2
-rw-r--r--sys-libs/libvpd/libvpd-2.1.3.ebuild33
-rw-r--r--sys-libs/libvpd/libvpd-2.2.4.ebuild36
-rw-r--r--sys-libs/libvpd/metadata.xml8
4 files changed, 79 insertions, 0 deletions
diff --git a/sys-libs/libvpd/Manifest b/sys-libs/libvpd/Manifest
new file mode 100644
index 000000000000..37d4a90a5eea
--- /dev/null
+++ b/sys-libs/libvpd/Manifest
@@ -0,0 +1,2 @@
+DIST libvpd-2.1.3.tar.gz 116493 SHA256 18390b1c272c774b153615a84d4f4e683da08156daf5a0b001c3c07f54d422ae SHA512 f5aac9253752552674ac6c54dd3e6dbdd7ff79867740076d6e19782940b809e53736a11e668978d8d73bf636d92d1daeb78080e5fd31c4febc2257e5497c373c WHIRLPOOL a0f34265c865282a755092c854521d538bbb633b92ff8004a7b8f4949a91bfd924ca156edd4357f67fbf62c7456e0785887a6e62e67f385d348aae8836c4b199
+DIST libvpd-2.2.4.tar.gz 374665 SHA256 13a44a156cfe60b6ee7c1f4dc9171335657bfd5903c59a686abf1149b1b12c12 SHA512 89f7e235e957393fe33e484b23fce15fbf36274db6115e7245027a17b7535e387f835c048a7063f317f10de2351a78acf2ca72b10adee0020ce62a035bfe787e WHIRLPOOL e902455cd34262f581af2af160c9f16c542a63a5c58121116be2d6eb3bf58cc6ec2ee2074ad45959f7d0add9836129bba884d264e970ac9b62edb720f19157ec
diff --git a/sys-libs/libvpd/libvpd-2.1.3.ebuild b/sys-libs/libvpd/libvpd-2.1.3.ebuild
new file mode 100644
index 000000000000..f9bda3facce4
--- /dev/null
+++ b/sys-libs/libvpd/libvpd-2.1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Library implementation for listing vpds"
+HOMEPAGE="http://sourceforge.net/projects/linux-diag/"
+SRC_URI="http://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
+
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="ppc ppc64"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.7.8
+ sys-libs/zlib"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_configure() {
+ ./bootstrap.sh
+ econf || die "Unable to configure"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "Something went wrong"
+
+}
diff --git a/sys-libs/libvpd/libvpd-2.2.4.ebuild b/sys-libs/libvpd/libvpd-2.2.4.ebuild
new file mode 100644
index 000000000000..220009728d95
--- /dev/null
+++ b/sys-libs/libvpd/libvpd-2.2.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils udev
+
+DESCRIPTION="Library implementation for listing vpds"
+HOMEPAGE="http://sourceforge.net/projects/linux-diag/"
+SRC_URI="http://sourceforge.net/projects/linux-diag/files/libvpd/${PV}/libvpd-${PV}.tar.gz"
+
+LICENSE="IBM"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DEPEND="
+ >=dev-db/sqlite-3.7.8
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ # sysconfdir is used only to establish where the udev rules file should go
+ # unfortunately it also adds the subdirs on its own so we strip it down to
+ # dirname
+ econf \
+ $(use_enable static-libs static) \
+ --sysconfdir="$( dirname $(get_udevdir) )"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install
+ prune_libtool_files
+
+}
diff --git a/sys-libs/libvpd/metadata.xml b/sys-libs/libvpd/metadata.xml
new file mode 100644
index 000000000000..8dc591673f73
--- /dev/null
+++ b/sys-libs/libvpd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc64</herd>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+