summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/sparse-0.6.4-r2.ebuild8
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-devel/sparse/sparse-0.6.4-r2.ebuild b/sys-devel/sparse/sparse-0.6.4-r2.ebuild
index b682f26a5aba..66b164b12383 100644
--- a/sys-devel/sparse/sparse-0.6.4-r2.ebuild
+++ b/sys-devel/sparse/sparse-0.6.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,7 +23,7 @@ IUSE="gtk llvm sqlite test xml"
RESTRICT="!test? ( test )"
RDEPEND="gtk? ( x11-libs/gtk+:3 )
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
+ llvm? ( <llvm-core/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
sqlite? ( dev-db/sqlite:= )
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}"
@@ -31,8 +31,8 @@ BDEPEND="gtk? ( virtual/pkgconfig )
xml? ( virtual/pkgconfig )"
llvm_check_deps() {
- has_version "sys-devel/llvm:${LLVM_SLOT}" && \
- has_version -r "sys-devel/llvm:${LLVM_SLOT}"
+ has_version "llvm-core/llvm:${LLVM_SLOT}" && \
+ has_version -r "llvm-core/llvm:${LLVM_SLOT}"
}
pkg_setup() {
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index b682f26a5aba..66b164b12383 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,7 +23,7 @@ IUSE="gtk llvm sqlite test xml"
RESTRICT="!test? ( test )"
RDEPEND="gtk? ( x11-libs/gtk+:3 )
- llvm? ( <sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
+ llvm? ( <llvm-core/llvm-$((${LLVM_MAX_SLOT} + 1)):= )
sqlite? ( dev-db/sqlite:= )
xml? ( dev-libs/libxml2 )"
DEPEND="${RDEPEND}"
@@ -31,8 +31,8 @@ BDEPEND="gtk? ( virtual/pkgconfig )
xml? ( virtual/pkgconfig )"
llvm_check_deps() {
- has_version "sys-devel/llvm:${LLVM_SLOT}" && \
- has_version -r "sys-devel/llvm:${LLVM_SLOT}"
+ has_version "llvm-core/llvm:${LLVM_SLOT}" && \
+ has_version -r "llvm-core/llvm:${LLVM_SLOT}"
}
pkg_setup() {