summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/raspberrypi-mkimage/raspberrypi-mkimage-0_p20120201.ebuild')
-rw-r--r--sys-boot/raspberrypi-mkimage/raspberrypi-mkimage-0_p20120201.ebuild30
1 files changed, 16 insertions, 14 deletions
diff --git a/sys-boot/raspberrypi-mkimage/raspberrypi-mkimage-0_p20120201.ebuild b/sys-boot/raspberrypi-mkimage/raspberrypi-mkimage-0_p20120201.ebuild
index ecbea00e0dce..202e65282d26 100644
--- a/sys-boot/raspberrypi-mkimage/raspberrypi-mkimage-0_p20120201.ebuild
+++ b/sys-boot/raspberrypi-mkimage/raspberrypi-mkimage-0_p20120201.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+EAPI=6
-inherit eutils distutils-r1
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
DESCRIPTION="Raspberry Pi kernel mangling tool mkimage/imagetool-uncompressed.py"
HOMEPAGE="https://github.com/raspberrypi/tools/"
@@ -16,7 +18,9 @@ KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND=""
-RDEPEND="${PYTHON_DEPS}"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-imagetool-uncompressed.patch )
src_unpack() {
mkdir "${S}" || die
@@ -24,26 +28,22 @@ src_unpack() {
}
python_prepare_all() {
- epatch "${FILESDIR}"/${P}-imagetool-uncompressed.patch
sed -e '/^load_to_mem("/s:(":("'${EPREFIX}'/usr/share/'${PN}'/:' \
-e '1s:python2:python:' \
-i imagetool-uncompressed.py || die
- python_copy_sources
+
+ distutils-r1_python_prepare_all
}
python_prepare() {
- cd "${BUILD_DIR}" || die
- case ${EPYTHON} in
- python3.1|python3.2|python3.3)
- epatch "${FILESDIR}"/${P}-imagetool-uncompressed-python3.patch
- ;;
- esac
+ if python_is_python3; then
+ eapply "${FILESDIR}"/${P}-imagetool-uncompressed-python3.patch
+ fi
}
python_compile() { :; }
python_install() {
- cd "${BUILD_DIR}" || die
python_doscript imagetool-uncompressed.py
}
@@ -51,4 +51,6 @@ python_install_all() {
insinto /usr/share/${PN}
newins {"${FILESDIR}"/${P}-,}args-uncompressed.txt
newins {"${FILESDIR}"/${P}-,}boot-uncompressed.txt
+
+ distutils-r1_python_install_all
}