summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/scsiping/scsiping-0.0.1.ebuild')
-rw-r--r--sys-block/scsiping/scsiping-0.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-block/scsiping/scsiping-0.0.1.ebuild b/sys-block/scsiping/scsiping-0.0.1.ebuild
new file mode 100644
index 000000000000..6a4868976bf4
--- /dev/null
+++ b/sys-block/scsiping/scsiping-0.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="SCSIPing pings a host on the SCSI-chain"
+HOMEPAGE="http://www.vanheusden.com/Linux/"
+SRC_URI="http://www.vanheusden.com/Linux/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e '/strip scsiping/d' ${S}/Makefile
+}
+
+src_compile() {
+ emake DEBUG='' CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin scsiping
+}
+
+pkg_postinst() {
+ ewarn "WARNING: using scsiping on a device with mounted partitions may be hazardous to your system!"
+}