summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/nbd/nbd-2.9.24.ebuild')
-rw-r--r--sys-block/nbd/nbd-2.9.24.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-block/nbd/nbd-2.9.24.ebuild b/sys-block/nbd/nbd-2.9.24.ebuild
new file mode 100644
index 000000000000..707fb257a232
--- /dev/null
+++ b/sys-block/nbd/nbd-2.9.24.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Userland client/server for kernel network block device"
+HOMEPAGE="http://nbd.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nbd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-lfs \
+ --enable-syslog
+}
+
+src_compile() {
+ emake
+ emake -C gznbd
+}
+
+src_install() {
+ default
+ dobin gznbd/gznbd
+}